Showing results for 
Show  only  | Search instead for 
Did you mean: 

Powershot G15 - How do you fire studio lights from the hotshoe?




I have a Powershot g15 and I can't figue out how to fire my studio lights fro the hotshoe. I had it working a few months ago but a con no longer find the correct series of setting to fire always. Do you know kniw the right combination of settings??







Usually these types of cameras have a flash control button.  Turn it to always on.  It’s probably a little lightning bolt (as opposed to a lightning bolt with an A next to it – for ‘auto’).  It’ll also matter what shooting mode you’re in, I’d use Manual, Av, Tv, or P.  Lastly, some of the hybrids won’t fire the flash if you’re in continuous mode, so turn it to single shot mode just in case.

Yea, I'm set in Manual Mode with Continuous mode turned off to single shot. Still not firing.. There's gotta be one more secret setting. When you hie the little lighting bolt icon nothing happens. If I remove the hot shoe connection, it will give me the always on option. 


I know this works, cause I've had it working before. Just can't remember the series of settings

Actually, that's kind of what I would expect it to do.  Usually when you connect something to the hotshoe it always triggers it.


What are you using to go from your hotshoe to the flash, a wired converter or RF triggers?

I agree with Skirball.  I have a G1 X - very similar to a G15.  If there's a flash connected to the hot-shoe then it fires (or you can get a wireless trigger in the hot-shoe, or an off-camera sync cord that adapts in via the hot-shoe.)


No special on-camera settings are required. 


Tim Campbell
5D III, 5D IV, 60Da

I agree too. When you plug in a smart flash to the hotshoe, it fires. However I'm using studio lights. An old Novatron system. I'm using a pixel FC-311 Flash gun cable then connected to the novatron sync cord. I've had it working in the past.


I do know that pluging the synce cord from the Novatron system will not work cause it has one pin instead of 5 for connection with the hot shoe.


If you have any ideas let me know.





Have you tested the flash, sync-cord, and adapter?


The foot of a flash is actually it's ground pin and it makes contact with the hot-shoe rails on the camera.  If you ground the center pin to the ground, the flash will fire.  So if you were to disconnect the hot shoe adapter from the camera and use a piece of metal to touch the center pin and ground pin (on the hot-shoe adapter... not on the camera) then the flash should fire.  If it does not fire then there's a problem somewhere in that path... either the adapter, sync-cord, or flash are having a connectivity problem.


Tim Campbell
5D III, 5D IV, 60Da

I have a similar problem. Using an old Sunpak 383 Super, it refuses to fire on my G15 except when the dial is set to "Auto" which obviously isn't working because in auto it set the exposure and then the light added by the flash washes out whatever you were trying to shoot. The same flash works fine on several other cameras, including an Olympus OM-D E-M1 which has a reputation for being finicky. 



Well, FWIW, I did a Reset All, and now it works, but for the life of me I couldn't get it to work beyond that. What setting or settings would disable the hotshoes like that? I'd like to know, so it doesn't happen again...