cancel
Showing results for 
Search instead for 
Did you mean: 

Help Please! LCD screen keeps going blank on SX70

ALB2018
Apprentice

I have been reading about this in other posts but they are for a SX60 and the answers do not apply to my camera. Each time anything gets close to the viewfinder the screen goes blank. I do almost all of my photography in a light box and many times the camera is at the top of the box and each time this will turn the screen off. I understand that the camera thinks my eye has moved to the viewfinder, but how do I turn off this feature?

Thank you so much!

1 ACCEPTED SOLUTION

I think you have to change the display mode from Auto to Manual as shown here:

SX70  Diplay.JPG

View solution in original post

4 REPLIES 4

AmandaC
Contributor

@ALB2018 wrote:

I have been reading about this in other posts but they are for a SX60 and the answers do not apply to my camera. Each time anything gets close to the viewfinder usps tracking the screen goes blank. I do almost all of my photography in a light box and many times the camera is at the top of the box and each time this will turn the screen off. I understand that the camera thinks my eye has moved to the viewfinder, but how do I turn off this feature?

Thank you so much!


Facing the same here too. Help is highly appreciated.

 

Thanks in advance.
Regards,

Amanda

I think you have to change the display mode from Auto to Manual as shown here:

SX70  Diplay.JPG

OMG Thank you so very much! This has driven me crazy and I couldn't find information on it anywhere.

 

Thanks again!

You're very welcome!

Announcements