Showing results for 
Show  only  | Search instead for 
Did you mean: 

imageCLASS MF4350d smudged and missing print


 I own a Canon ImageClass MF4350d printer and lately when I go to print, it misprints.  This really only happens when I'm trying to print multiple pages, and this only happened recently. I've had this printer for almost 230 years. At the top of the first page is what looks a smudged text of something from the next page, but on the next page it starts to show smudged toward the middle of the page, and only the middle of the text in the page, but as the page prints more the smudge just turns to blank spaces instead. If I try to print just one page at a time this doesn't happen. I have also tried to uninstall the drivers/software and reinstall them, but that didn't help. I also tried to change the usb cable and that didn't help either. Does anyone know how to solve this?image 2.jpgimage 1.jpg



Thanks for posting!

While our Forum Community members are welcome to chime in, your product has been retired and is ineligible for official support from Canon USA.

Once a product is retired, new drivers and software development stops, and official Canon support content (troubleshooting articles, user guides, how-to videos, etc.) can be removed from the Canon website.

To take advantage of Canon's innovative technologies, consider contacting our Canon Upgrade Specialists at 1-866-443-8002.

Have a great day!