Showing results for 
Show  only  | Search instead for 
Did you mean: 

imageCLASS MF264dw II - printer is not found during installation. Windows 10 sees this printer


Hi! I have a brand new imageClass MF264dw II printer/scanner. When I run MF260MFDriverV6101WP.exe downloaded from Canon I get to the dialog where there is a search for the device and it is not found. Without this driver I cannot run the MF Scan Utility  - it errs out with the message saying, "A scanner driver supporting this software is not installed...".

Things I tried:

  • I disabled McAfee firewall - no luck.
  • I uninstalled McAfee and cleaned up the registry - no luck.
  • I disabled Windows Defender Firewall after McAfee removal - no luck.
  • I disabled the firewall on my router - no luck.
  • I disabled 5GHz band - no luck
  • I disabled 2.4Ghz band and enabled 5GHz  - no luck.
  • Searched by IP - in the driver installation screen - no luck ( I CAN PING the printer just fine).

I am ready to return this unit. Anything else I can do ?



I have the exact same issue on windows 11


I managed to install the unit by connecting an external cd-rom and using the CD that came with the printer. The driver I downloaded must be a newer version and did not work.


So I had the same problem, I called Canon support at 1 (800) 652-2666 and it took a while but the guy was very nice and had to speak to another tech. He called me back and told me I had to Initialize all data settings. To do this: Press Menu then select "System Management settings" then on the very bottom of the list "Initialize all Data/Settings". It did the trick.