cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MFC8300c randomly stopped working half an hour after a successful print, on MacOS 13.1 Ventura

auros
Contributor

For years I've had the problem that if I woke up my laptop and printer from a sleep/idle state and tried to print, it wouldn't work, but turning the printer off for a minute and then back on would fix that.  This morning I went through that little ritual, printed a couple pages, then half an hour later I wanted to print another thing... and the printer has become completely unusable.  Initially, any time I would try to print, I'd get stuck at a "sending data" state.  After rebooting both the laptop and printer again, I tried "Reset Printing System" to completely wipe the settings on the Mac side, to re-add the printer.  Although that seems to have been a mistake, since now I've lost my presets for Color / Grayscale / B&W mode, and I realized I don't see the color mode anywhere in the print dialogue, or in the Settings > Printers dialogues.  But regardless of what color mode it's choosing, I still can't seem to print.  Considering how much I paid for this printer, and the fact that it printed two color pages just fine this morning, it is extremely irritating that I can't seem to use it.

6 REPLIES 6

auros
Contributor

I also tried updating the driver -- I went from Canon's 10.1 to 10.12 driver for this device.  Then I reset the printing system again, and re-added the printer.  Didn't make any difference.

auros
Contributor

On one of my most recent attempts to print, I was observing it was stuck in the "Sending data to printer..." state, and I looked at the print monitor on the printer's side, where it showed one job pending, in a "Waiting" state.  So it looked like the Mac had opened a connection to the printer to send a job, but then was just... not sending it.  I tried cancelling from the Mac side, and the printer continued to show that pending job.  So then I cancelled the job on the printer side as well.  Now when I try to print, the Mac hangs at "Ready to Print", and the printer never shows a pending job. 🤷

Hi, auros!

Thanks for posting on our forum! This community is designed for your fellow Canon owners to help each other out with any problems they may encounter. If this is a time-sensitive matter, click HERE search our knowledge base or register your Canon gear HERE to access additional support options.

Thanks and have a great day!

shadowsports
Legend
Legend

Greetings,

What is the printer connected to and how?  Router, computer...  ethernet, wireless, USB?

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It

I'm connecting to the printer over USB, from a MacBook Pro (recent vintage -- it has the M1 chip), running OSX Ventura (13.1 -- I put that into the subject line, which I wrote when I was working from that laptop, so presumably I checked in the About This Mac info when I wrote that).

I also did try adding the printer as a network device.  (Both the laptop and the printer are hooked into a basic D-Link desktop switch in my home office, which in turn is hooked to a port in my wall that goes to a 24-port switch in a closet at the center of the house, which is hooked to a Google WiFi router.  I have every room wired with Cat6, as well as GWiFi distributed through the house.  The Google system reports it can see the printer on the network.)

When I try to use the Printer over Bonjour, I get a similar behavior where the laptop hangs in a state where it's waiting to start the job; I forget the exact phrasing, I can check on it later.

A friend suggested I should poke around under ~/Library/Application Support and ~/Library/Caches to see if there's cached data that can be wiped out, followed by re-installing the driver...  I need to test that out tonight after work.

auros
Contributor

Well I didn't find anything that seemed relevant to Canon, either in my user library, or in the top level /Library/Application Support and caches directories.  I managed to print the thing I wanted to print, by way of resorting to exporting each page from the PDF as a JPG, and then using the USB direct-print.  (Apparently this model doesn't recognize PDF files, but will print JPGs.  Ugh.)  But I still really would like to resolve the larger problem. 😕

Avatar
click here to view the press release
Announcements