Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF743 need WinXP driver


Running a VM with WinXP32 in a Win7 64 bit PC. I need to print from the VM. Nothing I've tried so far will work. I can get the proper IP port to function and connect to the MF743, but no printing. I tried an earlier model XP driver and did get a print but it was gobledygook. Otherwise the most I get from the MF743 is an error beep.


The so-called generic driver that Canon has posted just returns an assortment of errors.



Hi rdgrimes.


The MF743Cdw is supported on the Windows operating system, from Windows 7 to Windows 10. There are no drivers for Windows XP. We are also only able to provide support when the printer is used with the local version of the operating system. Because of the type of environment, we are unable to guarantee communication through virtual machines. 


If you have any questions, please call us at 1-800-OK-CANON (652-2666), Monday - Friday 10:00 a.m. to 6:30 p.m. ET (excluding holidays).

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Thanks for taking the time to write the non-answer.

Actually I did find a driver that works to a point. But I had to go elsewhere to get it. GPlus_UFRII_V202 does work except it doesn't support all the driver settings like envelopes and auto paper select.

Virtually every previous Canon office MF does in fact work in XP and in VM environments, so this is a new departure for Canon. Nobody is asking for official "support", just a functioning driver.

I'm in the same boat.  Running VM of XP.  Could get my previous Canon printers to connect.  Not a brand new MF743 and I need it to.  A simple backwards compatable -even limited feature- driver from Canon would be great.

The use of the VM doesn't matter, the same issues occure in WinXP on a PC too. Here I can get most functions using the UFR-2 driver, but still have problems. I finally gave up on the MF743 and went back to a MF 733 which is the exact same machine.


Try using one of the drivers for the MF731/733.

How can you get the 733 driver to work?  There is no driver for XP listed.  Or was the 64 bit driver backwards compatable to XP?  Or maybe I'm not following you.

I use 32b WinXP, there should be a 32b driver listed. Try "[Windows 32bit] Generic Plus UFR II Printer Driver V2.30" in the Win10 list. There's also some drivers showing for Win7 that might get you somewhere.

Ah, there it is under win 10.  Thanks.  Ran out of time today to continue.  Will pick back up tomorrow.  Thanks again for the help.  Hopefully I can get a bit closer with your leads.  I'll update where I get.

Whaoo! Success!  Thank you rdgrimes for pointing me in the right direction.  Thank you too for responding to my reply to yours almost a year and a half later, and quickly!


I haven’t tested all the functions, but for what I need it works.  I'll describe what worked for me in case the three other people in the world that need this to work the way we do come looking. 


I searched for generic drivers under both the MF743 and MF733.  I selected operating system as windows 10 and also windows 7.  The generic driver “[Windows 32bit] UFR II Printer Driver V30.30” is listed under both operating systems and is the one that worked.  The generic driver “[Windows 32bit] Generic Plus UFR II Printer Driver V2.30” did not work for me. I downloaded it to a specific folder that I specified on my hard drive.  Make sure to unzipp the driver first in the same folder it was downloaded to.  Basically just double click the zipped folder and extract to same folder.


Inside the WinXP virtual machine or standalone pc go to “add a printer” under printers.  Select local printer attached to this computer.  Make sure the box “Automatically detect and install my plug and play printer” is unchecked.  Hit “next”.


Select “use the following port”.  You will need to select a TS port.  At this point it’s a guessing game as to what TS port the printer is connected to.  I started with the first active port and it happened to be the right one.  If not, you will need to go through the full printer install process with each TS port until you hit the right one. Click “next”.  Remember to delete the printer if it’s the wrong port and doesn’t work before starting again.


Choose “have disk” and then browse.  Choose the drive and folder you downloaded and unzipped the driver to.  Then choose the sub folder “drivers”.  Then choose “CNLBOU”.  Click “Open” and follow the steps to install and do a test print.  Once done and if the test print works its now an installed printer.


There may be other ways to do this, above is just what worked for me.

That all sounds painfully familiar.

With an actual XP-running PC you don't have to do the port dance, you just plug the printer into USB and go.

The VM adds all the port stuff. And be aware that if you change your USB config, add or remove USB devices, the VM will lose the printer and assign it to a different port.

click here to view the gallery