Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF4700n having IP address issues


I have been using the Image Class MF4700n for 3 months and yesterday it decided to stop communicating with the networked computers. It continues to work as a fax machine, but it won't automatically reassign the IP address, or allow us to manually assign an IP address. The printer has been reset and still doesn't work. Is there a warranty for this? I purchased through Amazon and was delivered July 30th. We didn't install it until mid August and now October 20th the system doesn't work as a printer. I appreciate any insight on fixing this or sending it back for another printer.



Hi Ia!

So that the Community can help you better, we will need to know what Computer Operating System you're using (Windows XP/Vista/7/8 or Mac 10.x).

Any other details you'd like to give will only help the Community better understand your issue!

If this is an urgent support need, please CLICK HERE to reach our friendly Technical Support Team by phone or email.

Thanks and have a great day!

I have Windows 7 on 3 of the computers and Vista on the dinosaur, which will be replaced shortly by a new system running Windows 8.


We run the printer through a netgear router because we have limited CAT5 ports. We changed the position on the router to see if the port went bad and it had no change/effect on the networking.


We did have an outage with our internet and brought the system down (including the modem) and back up. This put the internet back on, but the printer still isn't working. The primary issue is none of the computers see the printer. The IP address is in the printer, and I have asked it to reassign the IP address, I have also typed in a manual IP address (different than the auto assigned IP) and none of these things have allowed any of the 3 computers to see the printer. I have searched for the IP address through the computer as well. It is like the printer doesn't exist.

Hi la.


Thank you for your reply.


I understand that you have tried a different port on the router.  Is it possible to have you change the Ethernet cable?  After changing the cable, allow the IP address to be automatically assigned, and then open a web browser and enter the IP address of the printer.  Are you able to access the printer's Remote User Interface?


I look forward to your reply.  Should you need immediate assistance, please contact us at 1-800-OK-CANON (1-800-652-2666).


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.