Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10


I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.


I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:






I thought I would try to reinstall the MF Toolbox utility, but there are two problems.


1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.


2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:




I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.


I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.


Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.


(I can use the printer functionality just fine.)


Thanks.  My model's links are different, but the new software appears to work.


Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

434 REPLIES 434

I also had to clear the printer buffer , for a stuck job on another canon printer, to be able to uninstall those drivers.

I had already deleted everything and reinstalled a few times.   It was feeling rather pointlessly redundant.


This tool had been working well for 7 years till now. It stopped to scan a few days ago. After multiple reinstalling, driver/device removal from the system, reinstalling everything from scratch, again and again, I found the original disk, which was provided with the original hardware. After installation from that disk, everything got working again. So my question is: where is the progress, Canon? Why are you guys posting updates, that crash working hardware?

@Djekaster wrote:

 It stopped to scan a few days ago. 

I had the same problem after Windows 10 updates. It turns out that it's possible to run Canon MF Toolbox as administrator so everything works fine again

@volokolamsk-umc wrote:


I had the same problem after Windows 10 updates. It turns out that it's possible to run Canon MF Toolbox as administrator so everything works fine again

No, it doesn't.  I've tried it many times.

@scotty2541 wrote:


No, it doesn't.  I've tried it many times.

Have u tried to use Windows Fax and Scan app?
[Control Panel] -> [ Devices and Printers] - double-click the icon for the machine - scan 

I can print.  I don't fax from Windows.

When I want to scan, I get an error that the toolbox is the worng version.  EXCEPT IT'S NOT.


So 33% of what I bought this for doesn't work.  And Canon doesn't appear to give a ... "crap"

Here's a fix that always works for me:






‎08-20-2015 04:36 AM

This simple fix I found online worked for me:

Start> in the run box type. Services.msc

Scroll down to Windows Image Acquisition (WIA)

Right click, select Properties

Check that Startup type is set to Automatic

Click Log On Tab

Check that Local System account , and Allow service to interact with desktop is checked. Hit apply.

Click Recovery...Click on window next to First Failure, Scroll to Restart the Service. Hit apply.


@gnocchi wrote:

Here's a fix that always works for me:



Of course... no.  It doesn't fix anything.


Again, this is a CANON product, and CANON  software, and it's for the model of MF device I am using  (MF4890dw)...   Downloaded FROM THEIR WEB SITE.


And it doesn't talk.


When will CANON fix it??




This worked for me a couple years ago


I found this Scanner-only version at Canon Malaysia that installed (not available on Canon USA). So now I can use my network scanner again