cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10

mj1856
Apprentice

I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.

 

I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:

 

Error1.png

 

 

 

I thought I would try to reinstall the MF Toolbox utility, but there are two problems.

 

1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.

 

2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:

 

Error2.png

 

I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.

 

I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.

 

Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.

 

(I can use the printer functionality just fine.)

1 ACCEPTED SOLUTION

Thanks.  My model's links are different, but the new software appears to work.

 

https://www.usa.canon.com/cusa/support/consumer/printers_multifunction/imageclass_series/imageclass_...

 

Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

435 REPLIES 435

I finally called the Canon Tech Support help line. The Toolbox software was being installed in the wrong folder. The agent on the helpline quided me through the process to fix the problem. Now everything works as before.

good news...which folder is it supposed to go in?

Eagle3x8
Contributor

Me too, printer is 216n. Four calls to Canon tech support did not solve the problem. MS did not find any problem with my PC OS.

Eagle3x8
Contributor

A third party VueScan utility works great and is more comprehensive than ToolBox 4.9.. Costs $40. Canon has better shape up and fix its sofware instead of blaming the problem is with the customer's computer.

patmah
Contributor

"Start> in the run box type. Services.msc

Scroll down to Windows Image Acquisition (WIA)

Right click, select Properties

Check that Startup type is set to Automatic

Click Log On Tab

Check that Local System account , and Allow service to interact with desktop is checked. Hit apply.

Click Recovery...Click on window next to First Failure, Scroll to Restart the Service. Hit apply."

 

This was posted awhile back(msg 23) in this thread. PiersA, and originally somewhere by Captret.

I wish people would just do their research and take time to read through a thread instead of just repeatedly asking a question and expecting it to be handed to them on a plate.

The response above has helped ALOT of people. Its SIMPLE, its EASY, it WORKS for many people- including me.

Try it, and if it works, thank(kudos) PiersA and Captret. That way when others go through the thread they can see that post got lots of kudos and therefore is a good bet.

In this way you also help others instead of just yourself.

Rant over.... 😕

Sorry, but just like with every other "quick and easy solution", this one also fails.  Since converting over to windows 10, my imageclass MF229dx does not communicate with my computer for scan functions.  Prints fine, but cannot be found by the computer.

 

Even 2 hours on canon support could not help.  Of course they blamed it on Windows and told me that they have not had this problem....until I saw this forum and see that it is universal.

Re: MF Toolbox doesn't work on Windows 10 (Canon Community Subscription Update)

VueScan works. has a trial version. mf tool bx wrks in my w10 but not w7. no help from canon.
 

Too bad it didnt work for you. I had same prob. Couldn't scan, computer wouldnt recognize, but could print ok.

I have imageclass something. Not sure, I not very computer literate. GREAT printer machine tho, so I glad its all fixed for me.

I did just like the guy said and voila!

**bleep**, gotta love it when that happens!

Good luck to you.

It is dissapointing that Canon is not backing up their product....

Great news!!!! After endless frustration and more reinstalls of drivers than I can count, I have finally solved the constant problems using my Canon MF 4150 with a Windows 10 computer.

 

I purchased a Brother MFCL2750DW. Now I can scan with a click of the mouse, even after a Windows update.

 

When I was looking at new printers, I did not even consider a Canon due to the ongoing lack of support in providing drivers, even though the Canon was a great machine.

 

If a company isn't willing to make the needed investments to keep their software up to date, I have no faith that they will do so in the future with any machine I purchased now.

 

 

This actually worked for me HOORAY! - the v4.9 of the MF ToolBox
http://support-sg.canon-asia.com/contents/SG/EN/0200155904.html
[Windows 32bit & 64bit] Tool Box Ver.4.9.1.1.mf18
Last Updated : 15-Jun-2016
Issue Number : 0200155904

Previously I had also tried to update the firmware via USB - failed to connect. YMMV
http://support-sg.canon-asia.com/contents/SG/EN/0400301404.html
[Windows] MF4580dn/MF4570dn/MF4550d/MF4450 Firmware Update Tool (V12.01)
Last Updated : 13-Mar-2017
Issue Number : 0400301404

Tried this this but it failed to do anything:
[Windows 32-bit & 64-bit] Patch for Network Scan, USB Scan (Windows 8/8.1/10)
Last Updated : 18-Jan-2018
Issue Number : 0100765702

OS
Windows 10
Windows 10 (x64)
Windows 8.1
Windows 8.1 (x64)
Windows 8
Windows 8 (x64)
Outline
This patch resolves an issue that prevents scanning with a USB connection after upgrading Windows to a newer version.
If you cannot scan with a USB connection, install this patch.
If installing (or reinstalling) the MF driver, be sure to first restart (not shut down) your PC after driver installation is complete, and then install this patch.

If you are using USB scan, be aware that it may cease functioning after any future upgrades to Windows.
If this occurs, install this patch again.

After installing this patch, if the message prompting you to restart your PC is displayed, restart (not shut down) your PC.
* If you do not restart your PC, this patch will not take effect.

http://support-sg.canon-asia.com/contents/SG/EN/0100765702.html
Avatar
click here to view the gallery
Announcements