Showing results for 
Show  only  | Search instead for 
Did you mean: 

MAXIFY MB2720 Error Code 5200


I have an MB2720 multi use printer. It appears to be running fine in every way except when I try to perform any function (from scanning, copying, printing, cleaning) the machine will start the function and then default to an 'error code 5200' everytime.

Is there any fix for this?

There does not appear to be anything wrong with the machine.  The ink cartridges all appear fine and full. There is no paper jam in the machine. I am at a loss.



I should have also noted that I have tried turning the printer on and off and unplugging it multiple times.

It will reset the error code and turn back on and go to the 'Home Screen' like everything is good, but the moment you try to perform any function it returns to the same 'error code-5200'

Hello DarrenQ,

The 5200 error would point to a problem with the print head in the MB2720 or a problem with the ink system. If you have tried turning the printer off and on and the inks are seated properly, it looks like the printer needs service. You can check your available service options by logging into your MyCanon account using the link HERE


Thank you Hector.