cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ImageClass MF743CDW becomes unresponsive in MacOS

jwalters
Apprentice

Hi,

 

I have an ImageClass MF743CDW that prints great, but has a really annoying habit of becoming unresponsive in our Mac/iOS dominated house.  The basic issue is that the printer will work fine for awhile, then one or both Macs running MacOS Mojave will suddenly be unable to communicate with the printer.  So far the solution has been to delete the printer from the print queue, reinstall the printer, hope that it finds all of the functions (which doesn't always happen) then print for a period of minutes, days or weeks and repeat.  In fact, as I write this, I set up the printer about 20 minutes ago and MacOS is already unable to print to it, after doing so once and scanning once.  The symptom is always the same, the print queue is stuck "looking for printer."  

 

It's becoming rather annoying.  I've reset the entire print subystem with no improvement.  Is there any solution to this problem?

 

3 REPLIES 3

shadowsports
Legend
Legend

Greetings,

How are these devices communicating?

 

Based on your description, it sounds like the printer and Macs are connected to the same network?

 

Does the printer show as "offline" when you cannot print to it?

 

3 things come to mind.

 

-Drivers issue

 

-Issue with your router, AP or network configuration

 

or

 

-The printer is not waking or coming out of sleep when a print job is sent

 

A few steps you can perform to troubleshoot:

 

Drivers:

First step.  Confirm the drivers you are using are correct for the MAC OS you have installed.  If you upgraded the OS from an earlier version using an earlier driver, confirm that driver is compatible with Mojave.  If unsure, you can download the Mojave drivers here:

 

Support | Color Laser | Color imageCLASS MF743Cdw | Canon USA

 

Network Configuration:

Don't rely on DHCP.  Assign the printer a static IP on your router.  After doing this you will need to restart the printer and ensure its using the assigned IP.

 

Then remove the printer from your MACs and resinstall the printer using its IP.  

 

Refer to this article:

 

Add a printer on Mac - Apple Support

 

Scroll down to the section on adding a printer by its IP.

 

Power Save or Sleep:

The last portion can probably be confirmed once you have ruled out the above 2 items.

 

You should always be able to ping another device on your network using its IP address if its turned on.  Once you have assigned a static IP to the printer, you can also open its webserver in a browser using that IP.

 

If the printer is not sleeping, see if you can ping it using terminal or open its web server in a browser.

 

If this works the printer is installed correctly and your network configuration is correct.  When the printer is asleep you can try pinging it again and opening its webserver in a browser.  If you can't look at the printers power save, sleep or ECO settings.

 

Hint: you can using the "moon" icon button onthe control panel to put the device to sleep for testing.

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thanks for the follow-up.  It turns out that I'd addressed your suggestions, but that brought to mind another potential issue - wifi signal strength, or (potentially) flaky wifi support.  I've disabled the onboard wifi and ran an ethernet cable to see if that addresses the isues.  So far, several days in, things seem stable.  

pinthea
Contributor

SOLUTION:

What made the whole problem go away is that I did this:

1.  Setup the printer with a static IP address (don't use DHCP).  It doesn't matter if you're printing wirelessly or have it connected via ethernet.  This is critical because you'll need the static IP address later in these steps.  After you have done so, restart the printer and ensure that it's using the static IP address.

2.  Download the latest drivers from Canon's website.  Install them.  (YMMV whether or not this will all work when trying to connect via AirPrint from your Mac, I used Canon's drivers.)

3.  Remove the printer from MacOS.  Remove the Fax too if you have an entry for that.  Reboot if you want to, never hurts after doing something like this.

4.  Add the printer.  DO NOT use the first tab where it auto-detects and finds it via Bonjour.  Instead go to the 2nd tab (that looks like a globe) and add it using the IP address that you established in the previous step.  IPP is the default protocol, keep it.  Then you MUST select in the "Use" field the printer driver you installed in the previous step.

5. If possible, I'd also recommend NOT using WiFi as the way to access the printer on your network, use an ethernet cable to connect the printer directly to the router.  (I have not done this but it is always recommended!)

6. You can also configure the printer's WiFi settings (if you didn't listen to me in step 5) to disable the printer's WiFi power management setting (turn it off), that was highly recommended in another post and as far as I can tell it couldn't hurt.

As far as I can tell, step 4 is important because it tells the driver "always find the printer at this IP address" and bam, even when it's asleep, I can print to it from my Mac, even via WiFi, when I couldn't before.

This raises the question "What about my iPhones and iPads?" which are devices where you don't actually install any print drivers and it relies on AirPrint?  I don't know, I haven't toyed around with that just yet.  But these steps got me printing from my Mac even after the printer went to sleep and would otherwise have shown as offline.  I hope this works for you.

Avatar
click here to view the gallery
Announcements