cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Image class mf644

Jgcool
Apprentice
Worst experience with the printer ever. I could never just print, I always have to power down and power it up again in order to get my MacBook or iPhone to see it. Many numerous calls to Cannon and they have never been able to fix this. Constantly have me change things that they say will fix it in no way does it ever. Wish I had bought an HP.
7 REPLIES 7

shadowsports
Legend
Legend

Greetings,

How is this printer connected?  If wired or wireless, have you tried assigning the printer a static IP address?

 

Why leave things to chance.  The address can be assinged on the printer, or your router.  What remains constant..  the destination IP of the printer.   

 

 

 

 

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It

Jgcool
Apprentice
Yup, that was the first thing Canon had me do. Thought that was the answer, but no. Then Air Print turned on, again no. Then turned off sleep mode, again no. Turned on direct print last night so we’ll see on that one. Not sure how to use that though as it has an ip all it’s own.

Hi Jgcool.

 

If your router/network supports 5G, make sure the Macbook and iPhone aren't auto-connecting to the 5G connection.  It's common for 5G routers to keep communications from 5G and 2.4 GHz wifi separate to keep the 5G transmitting faster.  It's an easy-to-overlook cause of this type of problem.

 

Are you using signal repeaters or a mesh network?  Such networks may require additional work to ensure data is transmitting correctly between the printer on its node and the computer on its node.

 

Can you use the printer's IP address to reach its Remote UI?  If you can reach the Remote UI, then something on the computer/phone is blocking the printer from working.  This issue is more likely to occur on a computer than with an iPhone.

 

If this answered your question, please click the Accept as Solution button, so others might find the answer.

Jgcool
Apprentice
I’ll have to take a look again at which network everything is using. They were originally on the 2G network. I may have switched everything to the 5G in an attempt to get things working. I can use the printers IP address to get to it but I think as much I have to reboot the printer in order for that to work as well.

bgramreefer
Apprentice

I agree completely. I am sorry I ever bought this printer. I have spent more time getting to connect to network than actually using the printer. Everytime I go away or leave it for 10 days and come back to it the MacBook can't find the printer. I am unable to add the printer because it is not seen in the default list. I try to add a printer and that does not workl The printer works ok but the networking is FOR **bleep**.

 

Canon support is soooo hard to reach as well. Canon has nev er been able to fix this. FOr months scanning did not work. Like they have one guy programming drivers and know nothing about MAc OS updates. Cheap.

 

I pruchase two of these, one for home office and one for school classroom. Then I found out my BIG MISTAKE.

 

MacOS users. RUN AWAY from CANON PRINTERS as FAST AS YOU CAN.

I changed the following settings and it fixed the problem - I now have the Printer set to sleep after 1 minute and Air Print works All Day!!

 

1.  Change the Wireless LAN ECO mode setting to OFF

     Home  >>  Menu  >>  Preferences  >>  Network  >>  Wireless LAN Settings  >>  Power Save Mode  >>  Off
 

This ensures the Wireless connection remains ON while the Printer is in Sleep Mode allowing wireless printing (Air Priint and PC/MAC Printing) to connect to the printer and accept print jobs while the Printer is in Sleep Mode

 

2. Change the Wireless IP address to a Static IP address instead of a Dynamic IP Address (DHCP)

    Home  >>  Menu  >>  Preferences  >>  Network  >>  TCP/IP Settings  >>  IPv4 Settings  >>  IP Address Settings  >>  Auto Acquire  >>  Off

 

   Home  >>  Menu  >>  Preferences  >>  Network  >>  TCP/IP Settings  >>  IPv4 Settings  >>  IP Address Settings  >> Manually Acquire  >> [ Enter your Home network specific IPv4 settings ] 

 

This ensures the IP Address assigned to the printer does not expire (DHCP lease timeout) while the printer is in sleep mode. 


Note: If you turn Auto Acquire ON and let the printer obtain a dynamic (DHCP) IP address and then turn Auto Acquire OFF the Manually Acquire will retain the previous Network settings and they can be used as is to create a Static IP Address.

 

3. Change the Wireless LAN Settings to use a TLS connection for IPP printing

    Home  >>  Menu  >>  Preferences  >>  Network  >>  TCP/IP Settings  >>  IPP Print Settings  >>  Allow IPP Printing Only w/ TLS  >>  On

 

The Apple Air Print protocol relies on the Internet Printing Protocol (IPP) and requires a secure encrypted connection (TLS).

 

I'm not 100% sure if all three (3) of these options are requried to support Air Print.

 

I had options 1 and 2 enabled for some time and did not have success with Air Print until I applied option 3 (IPP over TLS).


These instructions are for a MF743CDW printer, but I suspect all the ImageClass MF6xx and MF7xx series printers are the same - YMMV

 

I hope this information helps someone else down the road!!

This has been the most helpful advice so far. I have the MF644cdw and a couple of Macbook Pros. I made the mistake of getting this printer for my wife's business. It has been a nightmare trying to get this thing to consistantly print without having to keep reinstalling the device or rebooting. I actually had to replace the printer with an HP and had to take the MF644 home becuase my wife needs a reliable printer. I'm extremely disappointed with this printer. I tried your suggestions and so far it is working from home.  Thanks for the post.

Avatar
click here to view the press release
Announcements