cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Selphy CP900 compatible with iPhone 11

Marissa1
Apprentice

Hi!

I was just wondering if the Selphy cp900 is compatible with the iPhone 11 phone.

thanks so much,

marissa

1 REPLY 1

rs-eos
Elite
Elite

If you are referring to the the Canon PRINT app, it requires iOS 15.0 or later which the iPhone 11 can indeed run.  See iOS 15 and iPadOS 15 Device Compatilibity List.

--
Ricky

Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers
Avatar
click here to view the press release
Announcements