cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Selphy App and Selphy CP1500 not compatible with iPhone 15

PennyV
Apprentice
  • Hi I have an iPhone 15 Pro and cannot get the Selphy app to download.
  • When I try to use the canon print app instead, I am notified that the Selphy cp1500 is not compatible with phone.
  • I’ve tried to plug phone in directly to printer via USB. Receive an error stating device is unsupported 
  • please help
3 REPLIES 3

Danny
Moderator
Moderator

Thanks for joining the conversation, PennyV!

So that the Community can help you better, we need to know exactly which version of iOS is running on your iPhone. That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

PennyV
Apprentice

My phone is running 17.1.1 

Please let me know what other information you may need to help with my question 

PennyV
Apprentice

I’ve worked out what the issue is.

The firmware in the printer needed to be updated. To do this I had to download the Selphy photo app.

Due to having a new phone there were some glitches in the app shop and I actually couldn’t download many apps - not just the canon selphi app.  I resolved this problem and updated the firmware in the printer via the app. 

thanks for trying to help resolve this issue 

Avatar
click here to view the press release
Announcements