Showing results for 
Show  only  | Search instead for 
Did you mean: 

8600f scanner


I have a Canoscan 8600f scanner and having problems with scanning film.


I am using a windows 7 system and have downloaded the latest drivers and toolbox. The scanner works great in reflective mode, but in the toolbox there is no selection for film. (only fpr Platen).


I was able to scan film when using Windows XP, but this is the first time I tried it after upgrading to Windows 7.


I have tried to use the app Vuescan and it does give me the ability to scan film, however it doesn't handle multiple frames properly. Also, It was only a trial version and don't want to purchase it.


Is this an issue with Windows 7 drivers? Or is there something else I should try?





Hi CharlieFO,


To scan film using the scanner, please follow the steps shown here from within the CanoScan Toolbox.  If the FILM option is unavailable, please try uninstalling the CanoScan Toolbox, then restart your computer and download and install the program again from the SOFTWARE section of the Canon USA website here.  


Should you still experience difficulty scanning film, we ask that you please contact a Canon technical support representative here for further assistance.  A representative will be happy to assist you free of charge.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Enter for a chance to win