Showing results for 
Show  only  | Search instead for 
Did you mean: 

Installing EOS Webcam Utility Pro 2.0: Service 'EWCService' (EWCService.exe) failed to start



I am attempting to install the EOS Webcam Utility Pro 2.0 software ( During the installation process, I receive the following error message:



  • EOS Webcam Utility Pro 2.0
  • Canon EOS Digital Rebel SL2 (200D)
  • Windows 10 Pro (22H2)

What I have tried

  • Downloaded the latest software ( from Canon's support website
    • Unblocked the download
    • Unzipped the contents of the download into a new folder
    • Ran the installer (Setup.exe) as an administrator
  • Restarted the computer
  • Manually started the service (EWCService.exe) via Task Manager and Windows Services
  • Attempted to install the program into different locations:
    • c:\Program Files\Canon\EOS Webcam Utility\ (the default)
    • c:\Program Files (x86)\Canon\EOS Webcam Utility\ (with other Canon utilities)
    • d:\EOS Webcam Utility\ (on a different drive)
  • Granted "Administrators" and "LOCAL SERVICE" full control on the installation folder (reference)
  • Ran CHKDSK /F on the drives I've attempted to install onto (i.e., c:\ and d:\)
  • Updated my Local Group Policy Editor so that the "Log on as a service" permission was granted to LOCAL SERVICE as well as my administrator account

Error Messages

EOS Webcam Utility Pro Setup

As reported at the top, the error reported by the installer is:

Service 'EWCService' (EWCService.exe) failed to start. Verify that you have sufficient privileges to start system services.

Windows Services

If I access my Services, locate "EWCService", and choose "Start", I receive:

Windows could not start the EWCService service on Local Computer. Error 1053: The service did not respond to the start or control request in a timely fashion.

Windows Event Manager

There are two separate application errors logged in the Windows Event Manager (1000, 1005), followed by a standard Windows Error Reporting Event (1001).

Event 1000, Application Error

Faulting application name: EWCService.exe, version:, time stamp: 0x636057d1
Faulting module name: EWCService.exe, version:, time stamp: 0x636057d1
Exception code: 0xc000001d
Fault offset: 0x000000000002631a
Faulting process id: 0x6eac
Faulting application start time: 0x01d968bc98a19858
Faulting application path: C:\Program Files\Canon\EOS Webcam Utility\EWCService.exe
Faulting module path: C:\Program Files\Canon\EOS Webcam Utility\EWCService.exe
Report Id: 8884304b-8785-460c-8921-1969d5e16709
Faulting package full name:
Faulting package-relative application ID:

Event 1005, Application Error

Windows cannot access the file for one of the following reasons: there is a problem with the network connection, the disk that the file is stored on, or the storage drivers installed on this computer; or the disk is missing. Windows closed the program EWCService because of this error.

Program: EWCService

The error value is listed in the Additional Data section.
User Action

  1. Open the file again. This situation might be a temporary problem that corrects itself when the program runs again.
  2. If the file still cannot be accessed and 
    • It is on the network, your network administrator should verify that there is not a problem with the network and that the server can be contacted.
    • It is on a removable disk, for example, a floppy disk or CD-ROM, verify that the disk is fully inserted into the computer.
  3. Check and repair the file system by running CHKDSK. To run CHKDSK, click Start, click Run, type CMD, and then click OK. At the command prompt, type CHKDSK /F, and then press ENTER.
  4. If the problem persists, restore the file from a backup copy.
  5. Determine whether other files on the same disk can be opened. If not, the disk might be damaged. If it is a hard disk, contact your administrator or computer hardware vendor for further assistance.

Additional Data
Error value: 00000000
Disk type: 0

Related Reports

On February 11th, 2023, community member @RichardZ made a similar report. In that thread, however, he notes that the error message was misreported, as the service had, in fact, started. In my case, by contrast, the error message is being correctly reported; the service is unable to start.

Other Software

It's worth noting that I have successfully installed the following Canon software on my machine previously, and have no issues with them:

  • Canon EOS Utility 2.14.20 for Windows
  • Canon EOS Utility 3.16.11 for Windows
  • Canon Picture Style Editor 1.28.10 for Windows
  • Canon Webcam Utility 1.1

Notably, this incudes the previous version of the Webcam Utility—though version that was based on a driver, not a service and an application.




Try the following.  

When the error dialog pops up...

Windows+R key

Enter "services.msc" in the run dialog, press ok



Scroll to service EWCService.  Right-click on it and select properties.  Change start up type to disabled.  Now select stop service.  Once the service stops, press the re-try button on the error dialog.  The install should complete.  Change the service start back to Automatic, save.  Restart the machine and test. 

Note, disable the EOS Utility from starting automatically by right-clicking on its icon in the system tray.   v2.0 of the software differs from v1.  It might work with the EOS Utility but I have not tested this myself, so it might be best to disable it for testing.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thank you for your response. Unfortunately, this doesn't seem to solve my problem; it continues to give me the error message—and prompting me to "Retry" or "Cancel"—even when the service is disabled.

Note that I am unable to stop the service after disabling it because it isn't running in the first place; that's been the core problem I'm facing. 

The one difference with disabling the service is that I now receive a different error in the Event Log. Instead of the previously reported 1000 and 1005 events, I now receive an 11920 event from MsiInstaller, which just reiterates the error message from the installer:

Product: EOS Webcam Utility -- Error 1920. Service 'EWCService' (EWCService.exe) failed to start. Verify that you have sufficient privileges to start system services.

Obviously, that's not that useful, but it's interesting to me that it doesn't get logged when the service is set to "Automatic".

Do you have any other suggestions? 


Registered to this forum to say that I'm having the exact same issue.
The frustrating thing is that this was (mostly) working on my computer before reinstalling Windows 10 about a year ago.

Windows 10 ver. 22H2
Canon 5D Mark ii
Canon ip8720


I have tried al these listed methods including calling Canon Support.

Intersting I have 2 computers. Surface Pro windows 11 and  HP Pavilion windows 11.

Webcam utility will not install on Surface Pro. However the newer computer HP it does install with dificulty.. The wifi portion of the program work.  Therefore, I am canceling my paid subscription.  Canon have issues if they are going relase software for new machines only but created an enviroment to use older cameras (DSLR T-6)  they need to do butter for all there customer. I am wondering do the other camera manufactors are having the sam issues?

CORRECTION:  The wifi portion of the program DOES NOT work. 

Other computer manufacturers do not experience this or similar issues.  They do not offer this or a similar type of application, either.  

There are BOTH software and hardware prerequisites for running the Canon apps.  Just because your platform is running Windows 10/11 is meaningless.  First and foremost, you must meet the hardware specifications.

The Operating System requirements come second.   Platforms with upgraded Operating Systems from an earlier version of Windows are not supported.  If I were to guess at the reason, it would because the platforms that initially used an older version of Windows do not meet the current hardware requirements.

"The right mouse button is your friend."

If you have paid for a subscription, then I suggest that you contact Canon Support directly.  This is a user forum.  It is not Canon Support.

"The right mouse button is your friend."