Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility doesn't work with macOS Ventura


Hi there,

I've recently upgraded to macOS 13 (Ventura) and EOS Webcam Utility doesn't work anymore. I tried both amd64 (EOS Webcam Utility 1.0) and arm64 (EOS Webcam Utility 1.1) versions, but none of them work properly.

EOS Webcam Utility 1.0 freezes, and EOS Webcam Utility 1.1 only works once after a system restart when camera is turned on and off a couple of times, but then system loses the connection with the device.

Please publish a fix of the software as soon as possible for your customers like me who are depending on the camera for their day to day work.



I'm on the same situation, and I've got to admit it was my fault for not checking first if there was any other people impacted before to upgrade. Because there was already. You just need to take a quick look here in the Community.

While we wait for an update of EOS WebCam Utility certified for macOS Ventura, I recommend you, in the case you have an iPhone on iOS 16.1, to use it as webcam.
This is a new feature that works OOTB on macOS Ventura and iOS 16, and what saved my life since I upgraded, on Oct 27th. It works great even wireless, but better use it wired.

If you use an Android instead, you can use Camo app (free version), which works the same way.

Hopefully an upgrade will come in not so much time, but at least that way you will be able to use a quality camera for your WebCam requirements in the short term.

This iPhone workaround as the webcam also works excellently in OBS. If you have a newer GoPro camera, you can also use it until we get an update to use our EOS cameras again. 

So for my 5d MarkIV running Ventura 13.4.1 adding EOS Utility to open on login connecting the camera and turning it on. Then log out and log back in this worked for me. Good luck


Wait is over.

Go to Canon US download site, select your camera model, select macOS 12 (I know that Ventura is macOS 13, but the relevant version of Webcam Utility is available when you select 12 instead of 13).


Download and install EOS Webcam Utility Pro 2.0 (macOS) 

After a reboot, my EOS camera is working again with Teams and so thru USB on macOS Ventura.

Hope it can be helpful,

This still isn't working for me, it won't install onto Ventura. The contents of the download is still the file from Oct 31,2022. you can download it, but it wont macOS is preventing it from being installed since it's not for Ventura.


Screenshot 2022-11-17 at 10.14.40 AM.png

It's a long process but, backup your computer to Time Machine, reset your computer on System Settings, reinstall EOS Utility from the Japanese Canon site (translate to English), and it should work on Ventura. A community member genius suggested getting the getting the Utility directly from the Japanese Canon site. Very smart.

You have to uninstall the previous version of Canon webcam utility first.

Here's how to uninstall Canon's webcam plug-in. This won't have any affect on EOS Utility other than to disable the webcam functionality.

  1. Go to the Finder.

  2. From the Go menu on the menubar, choose Computer.

  3. Navigate to the folders: Library ➟ CoreMediaIO ➟ Plug-Ins ➟ DAL

  4. Find the file called EOSWebcam.plugin

5. Drag this plug-in to the Trash, or pick Move to Trash for the File menu.

6. You will be prompted to enter your computer password or fingerprint.

After doing that, you may install the new version of Canon Webcam utility Pro.
Restart your mac.

Remember that version requires you initiate the app to use your canon as a webcam, so before open you stream software (zoom, obs, etc), you may have to initiate the EOS WEBCAM app.

Good catch!.

I indeed removed previous version when I found it wasn't supported on Ventura.

When I installed v2 my Mac only had EOS Utility installed, but not previous Webcam Utility,

For the moment I've been having meetings during 1 week and so far so good on any of my 2 MBPs on Ventura.

You don't need to manually uninstall the utility files like that, each version of utility has it's own uninstaller, which is in the Applications folder under EOS Webcam Utility folder.

I've tried uninstalling the older version - I do that every time when I try another version. But it doesn't help, the discussed pro version (2.0) doesn't work at all for me. The only version that works half measure is the 1.1 version, then I need to restart my camera device and toggle camera view in meeting softwares for some time until it starts to work on a single stream. The same goes every time a share my cam, it's pretty annoying.

click here to view the gallery