Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility does not work on AMD Ryzen computers


The EOS Utility and EOS Webcam Utility do not work properly with AMD Ryzen-powered computers. I have a brand new Lenovo Legion 5 (Ryzen 7 4800h, RTX 2060 graphics).  While my 10 yearold Intel-powered desktop runs EOS Utility and EOS Webcam Utility perfectly, the brand new laptop does not.  I have tried every combination of reinstalling drivers, disabling EOS Utility, and every piece of advice I can absorb from these forums and from Google searches, including using different USB ports and different USB3.0 CABLES.  Nothing works, but I have seen other AMD Ryzen users report the same issue.  Please update your EOS Webcam Utility software so that it runs stable on AMD Ryzen machines, or at least acknowledge the bug and let us know when a fix is forthcoming. Thank you kindly.


I saw a post on Reddit with the easiest workaround to restore 100% operation. If you use a cheap USB hub in between your 5d mk iv and your Ryzen computer it solves all of the issues. A cheapo USB hub that's 12 years old solved all of my problems instantly. USB 2.0 was plenty fast for the EOS Webcam Utility.

Omg thank you! I spent the last 2 and a half hours troubleshooting a USB error with my Rebel T5. My PC is running on a Ryzen 5 3600XT and I couldn't for the life of me figure out why my cam wasn't being recognized by windows.


I pluggeg it in to a USB 3.0 hub and boom! Withing seconds my T5 was installed and the webcam utiltiy was up and running.

Seems AMD had USB issues with Ryzen 3000 and 5000. Bios updates will be released.

click here to view the gallery