cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility Keeps Disconnecting

ToxicLiyv
Apprentice

I have a Canon EOS Rebel T3i, Purchased in the USA. I am currently using this DSLR as webcam for my twitch streaming but from time to time I lose connection. I am currently doing mini usb to usb since this camera is not able to

put out clean HDMI.Error.png

Picture inserted is the error I am getting. 

Current version for EOS Webcam Utility is 2.0.12

8 REPLIES 8

Waddizzle
Legend
Legend

Could you provide more details about your issue?  

Are you using a Windows or Apple computer?  How long of a time frame is “from time to time”?

--------------------------------------------------------
"The right mouse button is your friend."

Using Windows 11. I was using OBS as a streaming software now i am using Streamlabs OBS and I still face the same issue. Camera disconnects randomly is kinda hard to pin point an time interval.


@ToxicLiyv wrote:

Using Windows 11. I was using OBS as a streaming software now i am using Streamlabs OBS and I still face the same issue. Camera disconnects randomly is kinda hard to pin point an time interval.


I do not have sufficient info to reproduce your issue.  For example, what are your camera settings?  Live View?  Movie Mode?  However, I do not think it makes that big of a difference.

The T3i is an entry level camera from almost a decade ago.  it was never designed for continuous HDMI video output, although there are YouTube content creators who claim to have found clever work arounds.

I ask how long before it shuts itself down because the camera is designed to shut itself down after 30 continuous minutes of video recording.  If you wish to have a Clen HDMI input signal without interruption, then I recommend upgrading the camera.

--------------------------------------------------------
"The right mouse button is your friend."

I Have the Camera setup to Manual mode. I asked a few folks in another forum if should I use the camera in Manual Mode or Video Mode and none of them replied so I left it in Manual mode. I am currently using Mini-USB to USB since the t3i is not capable of doing clean HDMI at least if I use something called Magic Lantern but I don't really want to go that route since doing the Magic Lantern options for clean HDMI seems tedious and prone to mess up the camera. 

 

Also the auto shutdown options is disabled. 

For the benefit of others who may read this post, do the following.

Do not disable or change the shutdown or power options.  Leave them at their default settings.  The WebCam Utility should be used in Video Mode, not a Live View Mode.  The camera should be connected using a USB data cable, not an HDMI cable.

--------------------------------------------------------
"The right mouse button is your friend."

For my understanding if i don't disable the auto shutdown the camera will **bleep** down after 30 seconds of whatever options has been selected in the menu.

I

Waddizzle
Legend
Legend

I recognize that it sounds counter intuitive to not adjust the power settings, but they should be left at their default settings.  

https://www.usa.canon.com/cameras/eos-webcam-utility 

Also, the Rebel T3i is not listed among the supported camera bodies, which does not mean your camera will not work with the Webcam Utility.  It only means that performance may be degraded in some way.

--------------------------------------------------------
"The right mouse button is your friend."

geecyway
Apprentice

my isuue was same , right now can connected as webcam
im using 60D and windows 10
so trying to uninstall the eos webcam utility and on screen from camera not displayed as cam .

Avatar
click here to view the gallery
Announcements