Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon EOS Webcam Utility Pro Does Not Show As Device In OBS or Streamlabs


January 21,2024 was the last time I remember my camera had the ability to connect to OBS through the EOS Webcam Utility. Starting February 4th, 2024 I noticed that my Camera no longer shows up as an eligible device in OBS or streamlabs. I have done everything possible. 

I have a Macbook Pro with a M1 chip and it is updated to Sonoma 14.2.1. 

I have done what Apple has told me to do and I put my mac into recovery mode and made the changes in the terminal. 

I have completely deleted and redownloaded both applications (both Canon EOS Webcam Utility & OBS & Streamlabs)

I have restarted my computer multiple times but nothing has worked. For some reason the EOS Webcam Utility is not showing up under devices in OBS or Streamlabs which makes me believe it is not an OBS problem, but a webcam utility problem. I will upload photos and a video to show you what it looks like in OBS. Please note that the device was not connecting even when I had my camera connected and the camera was showing in the EOS Webcam app but the device still wouldnt pop up in OBS or streamlabs. I even attempted to close out the EOS Webcam app. Nothing has worked. I am hoping someone can help. If there needs to be a patch, please patch it. Screenshot 2024-02-05 at 3.34.38 PM.png



Has your MacOS recently updated?  

Yes?  If so, then it’s not an OBS problem or a Webcam Utility.  It’s an Apple problem.  This happens all the time with Apple products.  They update their OS and break their code base in the process.  

This forum has many, many threads with this similar complaint about Apple platforms.  People perform an update and some of their apps stop working.  Apple does this every 2-3 months.

This happens to the other camera manufacturers, too.  Google it.

"The right mouse button is your friend."

Apple just released yet another update, Sonoma 14.3.  Version 14.2.1 was released in late December and they have already upgraded or updated it to 14.3. 

I suggest that you try upgrading to Sonoma 14.3, rebooting, re-install Webcam Utility, and then reboot again.  A

"The right mouse button is your friend."


EOS WebCam utility in MacOS Sonoma 14.3 still does not see any camera attached to the computer. I suspect this is an issue with the way the Canon driver is attempting to communicate with the OS. I'm not convinced this is an Apple issue.

Have you checked the Apple web site for fixes?  You may need to enable USB ports or something similar.  Their past updates have disabled certain types of USB devices being connected to the computer.  That is be best advice I have.  Good Luck.

"The right mouse button is your friend."

Microsoft releases updates to Windows, too.  Windows updates do not break existing applications.  Apple updates seem to always break existing applications.  That’s just the way it is.  Get used to it.

"The right mouse button is your friend."

I uninstalled EOS Webcam utility, restarted my Mac twice, and then did a fresh download and install and everything works now. I suggest you do the same. I'm running EOS Webcam v I downloaded it today from the Canon Website.