Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎07-25-2020

T6i Won't Take Pictures - Please Help

Hi all, I've had my UK Canon 750D (US Rebel T6I) for a couple of years now and it has recently developed an issue where it won't take photos when shooting through the viewfinder. Live view with touch shutter is fine, along with recording videos.

 

When i try to shoot normally the focus square will illuminate red in a more hesitant way and/or not at all and it will only take a photo after some time has passed, say 30 or more seconds (it seems random). Also, If i try to take a picture, turn the camera off and on again, it will take the picture after it restarts.

 

I shoot in all settings and have tried it in auto and manual with manual/auto focus on the lens. However, the issue still exists when shooting with no lens. I'm currently using a Sigma ART 35mm.

 

I've tried updating the firmware, formatting the card, using a different card and resetting all settings to no avail. There is no self timer on. It is on single shooting, whilst if i change it to continuous shooting it has a tendency to start taking constant photos once it finally takes an image.

 

Another issue is, I live in Japan with little Japanese ability, making getting local help slightly difficult. I will hassle a friend and try to have it looked at by a shop when I can but it will help to be able to better identify the issue first. 

 

Searching has turned up little info but I am unable to identify the fault for narrowing down the search parameters.

Esteemed Contributor
Posts: 3,475
Registered: ‎11-19-2017

Re: T6i Won't Take Pictures - Please Help

Greetings,

It seems you've done proper troubleshooting.

 

Reset, Test with lens on/off camera, different shooting modes, format card, etc.

 

Have you tried using a different battery?

 

Updating the FW is probably not one of the first things I might have done, but you're already passed that.

 

Chances are a repair will be the only solution if a battery doesn't help.

or

Maybe its time for a new camera given where you are.  

~Rick
Bay Area - CA
~6D2(v1.1.0) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~Pixma Pro-100 ~ImageClass MF644Cdw ~LBP622dw
Highlighted
Forum Elite
Posts: 14,137
Registered: ‎12-07-2012

Re: T6i Won't Take Pictures - Please Help

"I've tried updating the firmware,..."

 

That was not the problem but people always think it is, it seems.

Here is what you need to do, reset the camera. Menus, tools, clear all settings and clear all custom settings. Fully charge the battery. Format the SD card, preferably a new one. Set the T6i to P mode, kit lens on AF, ISO 200. Now go out side on a nice day and try it.  Take several differing shots.  If it works, great, if not call Canon repair service. Simple test.

EB
EOS 1DX and 1D Mk IV and several lenses!
New Contributor
Posts: 2
Registered: ‎07-25-2020

Re: T6i Won't Take Pictures - Please Help

Thanks for the input, i gave that a crack to no avail. Took the camera into a service center yesterday (with my Japanese speaking friend), they told me it needed to have some sort of major internal work done at a cost of approx. 220USD. It would take a month to process.

 

Anyway, I bit the bullet and bought a 9000D (EOS 77D elsewhere i believe). Thanks for your swift replies both, it's much appreciated.

Forum Elite
Posts: 14,137
Registered: ‎12-07-2012

Re: T6i Won't Take Pictures - Please Help

Smiley Sad Sorry but now you konw.

EB
EOS 1DX and 1D Mk IV and several lenses!
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement