Showing results for 
Show  only  | Search instead for 
Did you mean: 

my canon t3i dslr camera automatically stops recording after about 10 sec. using a class 10 card.




My canon t3i dslr camera stops recording automatically after about 10 sec. the manual said to use an SD card of class 6 or higher. I am using a class 10 and I have been able to record long videos in the past and all of a sudden the camera stops recording automatically after about 10 sec. Does anyone know why?  thanks



Hi apatelw6!


Not being able to test all available cards with our cameras, we cannot guarantee that all of them will work properly.  Even though the card you have is rated Class-10, this may still be a card issue.  Have you tried any other cards in the camera?


If this is a time sensitive-matter, additional support options are available at Contact Us.



Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


How old is this card?


Your card may be having errors.  You can attempt a low-level format (in-camera... make sure you check the "Low level" box).  


Do you have a different card you can use?  If your card is having errors, I wouldn't trust it (you can risk losing all your images.)


"Technically" the process of "writing" data to a flash memory card is a destructive process (the life of the card is reduced each time a "write" is performed.)   This is normally not a big deal because it's expected that you can write and re-wite to the same memory location in flash memory thousands of times (usually well over 100,000 times) before the life degrades to the point where the card can't be trusted.  The cards typically have "memory leveling" technology, and they can mark bad spots when they detect errors (and this is why it's important to pick the "low level" checkbox ... it should mark any bad spots as unusable so that the card will not attempt to write to the locations.)


The point is... think of these cards like the tires on your car.  They last a long time... but they technically do wear-out with use and it's expected that you'll eventually have to replace them.


Tim Campbell
5D III, 5D IV, 60Da

I know this is an old thread.  If I don't receive a reply to this I will start a new one, but I'm having the same issue.


I have a Canon Rebel t3i camera that is about 16 months old and has been pretty lightly used.  I have a SanDisk Ultra 16 Gb class 10 SD card.  For the last several months, I can't record video for more than 20 seconds or so.   It shuts down automatically.   I have done a complete format on the SD card on my computer, and followed with the quick format with the camera.  No improvement.


Is there something wrong with the camera itself?   It seems there are a LOT of reports of this problem, and I am finding myself in awkward situations, like when I promised my husband I'd videotape our daughter's play while he was away, and ended up with 3 or 4 20 second snippets instead of anything meaningful.

Can you help?

Hi rockinruby!


Thanks for posting.


The reason the camera stops recording after a short time is because the SD card you are using is not fast enough to keep up with the amount of data the camera needs to write to the card every second.  Sandisk, like other manufacturers, makes different speed rated cards.  There is usually an MB/s rating on the card or listed with the card's specifications.  I recommend that you use a faster card. 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

No, Mike, I'm sorry, but as I stated in my post above, I'm using:


SanDisk Ultra 16 Gb class 10 SD card


By all measures I have read, this SD card should be fast enough.  In fact, it WAS fast enough for my camera to record for the first couple of months I had it, then the problem developed.

If Canon deems this card inadequate, then I would appreciate it if you would post here the EXACT make/model/capacity/class card I should purchase to correct this problem.


Thank you for your time.

Hi Rockinruby.


We get this a lot here.  It turns out that even though the card is labeled as a Class 10 card, the most common problem when this occurs... is that it's still a defective card.


Sandisk is a good company and they generally make solid products.  But there are two risks... (1) even Sandisk will occasionally have a bad card or a card that fails prematurely, and (2) it's exceptionally easy to create a forgery (if you peel the labels off these cards, they all look identical.)  


When I buy cards (and I also buy Sandisk and/or Lexar cards), I'm careful to buy cards which well-exceed the specs necessary ... but I'm also careful to buy the cards only from reputable dealers.


If you do a search, you'll find LOTS of articles about fake cards with tips on how to avoid them or how to spot them.


But the bottom line ... at the end of the day you just want your problem solved.  If the card is bad, then there's nothing that you  would be able to do to the camera to make the problem away.  You would really need to replace that card.


The issue that you are having is somewhat common... there are lots of threads on this.  But the majority of these are actually solved simply by replacing the card with a known good card and without making any changes to the camera.  


It's not a guarantee that it's the card... but it's the most common cause.



Tim Campbell
5D III, 5D IV, 60Da

Excellent, thank you, Tim.  Any tips on where/how to be certain I get a "reputable" card?   If I go to a standard retailer -- Best Buy, CVS, Staples -- do you feel that's safe?   

Those should be safe.  It gets more questionable if a person were to buy from an unkown seller on eBay ... or an Amazon "marketplace" seller (where you aren't really buying from Amazon.)


I expect Best Buy, CVS, etc. are using buyers who work directly with Sandisk or Sandisk's distribution channels.



Tim Campbell
5D III, 5D IV, 60Da

Ok, thanks.   My current card came from a brick and mortar chain store.  But then again, as I said -- it worked fine for quite some time, so perhaps it has developed a defect.   I'll try a new one.  Crossing fingers...