cancel
Showing results for 
Search instead for 
Did you mean: 

Windows 8 and Rebel EOS XTi

wpgerhardt
Apprentice

I had no problems using Vista but I now have Windows 8 on a new machine.  I installed software from my original disc, no luck so I went to ypur website to upload new software, Image Browser EX - I guess this is the new download utility.  Regardless, I plug my camera to the USB cable and I get the message from the EOS utility: "Camera is not recognized".  I can see the camera under my computer (Displayed as a portable device: Canon EOS Digital Rebel XTi). Why won't the software automatically download the pictures like it did with Vista (separate files by date the pictures were taken etc.)?  Do I need something else?

16 REPLIES 16

jonathan
Apprentice

Without actually being in front of your system, it's hard to say what would work or not. Here are 3 different things you could try:

1. Leverage Compatibility Mode as much as possible.

Uninstall all Canon software and reboot. Then re-install everything, but pay attention to any dialogs that ask if the software has installed correctly. Answering "No" to that question should bring you to a compatibility assistant/wizard that will ask if you want to try it again or install/run it in Compatibility Mode. Choose Yes and accept the defaults to get it done.

I forget if it makes you plug in the camera during setup, but if it does, do so. If it doesn't force you to do that, don't do it (yet).

Find all the latest versions of Canon's software (Zoom Browser, EOS Utility, DPP etc) and make sure they are all upgraded to the latest versions. Plug in your camera and hope for the best.

The method is a little backwards because Canon won't let you install the latest software unless you've installed it from the CD originally (which is STUPID), but once you have all the latest software installed in compatibility mode,

2. Instead of left-clicking the icon for any of the software you are using, right click it instead and choose "Run as administrator." That might help too.

3. The other thing you can do that, quite frankly, will work way better is to not use any of the Canon software (other than the EOS Utility). Adobe Lightroom or Photoshop Essentials do what the other ones will do but 1,000 times better. Picasa might even work better, although I haven't tried that on Win8.

I'm running Lightroom 4.4 and I don't have anything but the Canon EOS Utility software installed on my Windows 8 system and it works like a champ.

If I think of anything else I'll post it, but at least you have some things to try.

6D, 7D, 70-200 f2.82.8 IS mkii, 17-40 f/4, 24-105 f/4, Various Yongnuo Flashes and triggers

Thank you for the info.

There have been several reports of issues with Canon software and Win 8. I have and use Win 8 and I have and use a Rebel XTi without issues. You must d/l from Canon the latest updates. Make sure you tell the Canon web site you need Win 8 when it asks. Other than that there doesn't seem to be a obvious reason for the problems. Some, even on this forum, have never got it to work.

The reason Canon requires you to have the original disks is without it anybody could d/l their software and use it for free. Not a huge deterrent but a step in enforcement. The last time I checked, the Nikon software was not free and a user had to purchase it, for instance.

Almost any of the after market post processing software is better and easier to use than Canon's free programs. The top of the list is Light Room. I would have said Photo Shop a few months ago but now a subscription is required to use it and I no longer recommend PS to anyone. If you can get a copy of the last purchasable version (CS6), it is, with out peer, the industry standard. Photo Shop Elements 11 is a viable option, too. AVS has a suite of software that is pretty nice and covers most needs.

GimpShop is a open source free PS look-a-like. It is less desirable than PS, but useable.

The only Canon software I currently use on any regular basis is EOS Utility. If I were you I would really try to get it to work and forget the rest.

Get Light Room 4.Smiley Very Happy

EB
EOS 1DX and 1D Mk IV and several lenses!

I updated the EOS Utility 2 to the latest version (1.1.0.3 for Windows 8.1 64bit) and connected my XTi. The EOS utility recognized the camera and downloaded images to the computer. Then I connected my 60D to the computer and it connected and downloaded images, too. But when I reconnected the XTi the EOS Utility loaded but the option to download images is grayed out. The software does seem to recognize the camera (it shows the correct folder and filename definitions for downloading in "Preferences"), it just won't allow me to download images. I tried to re-install the EOS Utility but it won't re-install over itself. Can anyone suggest what might have happened and what to do about it? 

 

Windows 8.1 (64bit)

Hi Doug_E!

 

Thanks for posting about this.

 

Let's check to make sure Windows itself is recognizing the camera properly.  Make sure the camera is connected and powered on, then look in the Device Manager for the camera.  To open the Device Manager, press the [Window+X] keys together at the same time, then select Device Manager from the small list that appears on your screen.

 

  1. Is the camera listed under Portable Devices or Imaging Devices?
  2. What does Windows recognize the camera as?
  3. Is there a "?" or "!" next to the camera?

If this is a time sensitive-matter, additional support options are available at Contact Us.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Thanks for the quick reply! 

 

Windows recognizes the camera under "Portable Devices" as "Canon EOS DIGITAL REBEL XTi"

 

But the EOS Utility doesn't show the camera name on the title bar, as it did the first time I connected it and as it does for my EOS 60D. It is as if the EOS Utility can only see one camera at a time, and it is locked to that one.

Hello Doug_E,

When attempting to download images to your computer with the EOS Rebel XTi, it should be the only camera connected.  You mention the computer itself seeing the Rebel, just not EOS Utility.  The EOS Utiltiy software makes a connection to one camera at a time and if you have an EOS 6D connected, it should be disconnected at the time you wish to connect up to the Rebel.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I only have one camera connected at a time. The computer sees the XTi as connected, but the EOS Utility does not allow downloading from it, even though in "Preferences" it correctly identifies the folder and file naming conventions I put in.

 

Checking on the Canon website, I see that there is no update for the EOS Utility for the XTi except for Windows 7. I guess that may be the problem. Odd that it would work once, but not after that.

I don't think EOSU will d/l the same image twice.  Have you already d/l them once?

EB
EOS 1DX and 1D Mk IV and several lenses!
Announcements
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM