Showing results for 
Show  only  | Search instead for 
Did you mean: 

Wifi issue between R7 and Google Pixels



Since the last update, I can't use the Canon connect app with my Google Pixel 6. Bluetooth connection is OK but I can't use wifi features.

I tried to reset connection, I tried a brand new Pixel 8 and I have the same issue.

I tried with an old Xiaomi and it works.

I think that Google and their uncompromising security policy has broken the Canon wifi connexion.

If I try to connect manually, my phone says "password mismatch".

I'm sure I'm not the only one 😞

Canon, could you please make something for us please ?

Thank you!


Thank you!

I think you can ask to be paid 😁

So Google reduced the timeout or Canon has a slowdown in their firmware.

They responded to my ticket: the canon app is not compatible with pixel tablets.

Thank you Canon 😮💨


I found another tip: you can use a double type C wire to connect the camera but you have to choose the option "prioritize connection with camera". If you don't do it, the connection fails.

Any response at all?

Canon R10 here with a Piel 6a, latest updates etc…

I just had more questions from the Canon support yesterday but not reply to share sorry.

Thanks for the update, keep us posted 😉

It has been such a long standing issue on so many incredibly common devices, the lack of official announcement from the port of Canon really is terribly frustrating!


Canon replied to me on Feb 28 with the following:

Thank you for your feedback. We are unable to detect the behavior with the camera on other mobile devices with Android. It seems to be a specific problem. I will pass on your information. Since the software is developed in Japan, we do not get feedback on the information.

Since there is probably not even a ticket system for such bugs here, I am very unsure whether anything will happen. The answer "Android 14" is incompatible with our app should no longer be a justification after 5 months (1 year after pre-release).


So if a Canon developer needs any information about this. Please contact me, I've a full capture of a failed connection, where the problem can bee seen quite nice.

We could investigate finding a lawyer to bring a class action. Many of us are still under warranty. If they are refusing to fix functionality we bought the camera with, that seems like an issue


I can confirm that I'm having the same issue with a Pixel 8 running the latest Canon firmware 1.4.0 on a Canon R10. I'm able to connect via Bluetooth, but I receive a failure when it tries to connect via wifi. 



I continue to have issues with Pixel 6a and R7.

As a sanity check (and out of desperation) I installed camera connect on my old Samsung Note 8 and it worked first time. So I can at least connect a phone to my camera again although I wish Canon would just fix it so I can use my Pixel 6a.


To anyone still following this post or still having issues with the Wifi connection between the Pixel phones and EOS R7, there is now an option in the Canon Camera Connect app which solves the problem.  You need to open the app, click/press on the three lines/menu button in the top right corner, find the Bluetooth/Wifi Connection switching heading and click on Security.  Change it from WPA-3 to WPA-2 and the wifi connection between the devices should then work.  


Great! I didn't known you can downgrade to WPA 2 in the app.
As this issue is caused by a race condition in the the WPA 3 handshare, using WPA 2 solves the problem for me.

PS: Has anyone checked if the new 1.5 Firmware solved the issue? (No note in the ChangeLog about it)

click here to view the gallery