Showing results for 
Show  only  | Search instead for 
Did you mean: 

WiFi connection


I cannot connect my Canon 6D with my iPhone 5 even after I installed the EOS Remote App. Camera's WiFi function is or was configured and I think I followed all the steps to try to connect camera to phone so I can transfer my photos.

Thank you.



Hi AlanK!


Thanks for posting.


We have a new app for download called Canon Camera Connect.  I recommend that you download it.  This is the new app being used to connect to not only our EOS models, but our PowerShots as well.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


I'm having a problem connecting to my iPhone 6. I had no problems using EOS Remote with both my iPhone and iPad. With the new Canon Connect app, I can connect with my iPad but not my iPhone. I have no trouble connecting to my iPhone in settings, and Canon Connect recognizes that I am connected but when I open the app I get the message "Operate the camera to establish a connection". Eventually, my iPhone reconnects to another wi-fi connection and I have to start over; same results again and again.


Not sure why things are different between the iPhone and the iPad, but they are.

Hello klrabbers, 


So that the community may assist you, I'd like to find out which camera you're using when this occurs.  With regards to it's connection, are you attempting to download images or make a connection to control the camera?  Which version of the OS is installed on your phone?  

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Camera is an EOS 6D; I'm trying to connect so I can control the camera. OS is 8.4.1 (most current).

Hello klrabbers,

We recommend uninstalling the application and then performing a complete reinstall.  Also check the connection mode on the camera.  

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Still will not connect using my iPhone, will only connect to my iPad. The old app worked great on both devices. Very frustrating not being able to control my shutter release and focus with my iPhone!

I had a similar problem with my LG V10 connecting to my 6D -- EOS Remote app would work, but Camera Connect would never detect the 6D. The smartphone would easily find and get an IP address from the camera, but Camera Connect would never detect the camera.

I fixed it by disabling the mobile data connection (e.g. 4G LTE). Once I did that, the smartphone immediately saw the camera.

My guess is that the Camera Connect app uses a different method of detecting the camera, and it was trying to detect the camera on the mobile data network, not the wifi network. Once I disabled the mobile network, the app detected the camera on wifi.

Thanks for the input and suggestions.


I tried a few different combinations but still cannot get a connection on my iPhone. I tried disabling LTE, even tried turning off all cellular data; neither one of those worked. I don't see any other settings that would apply. Still searching...

Hi , i have a problem with my Canon eos10. I had the app "canon camera connect" and it worked well with my phone, but then suddenly deleted the app and redownloaded it. Now it shows that i am connected with wifi of camera but the app says "operate the camera to establish the connection" , so it doesnt connect with the app.
I just tried to turn off the data and try again but didnt work. Maybe u know what else i can try ?
click here to view the gallery