Showing results for 
Show  only  | Search instead for 
Did you mean: 




I have a Canon 5D Mark 2. I have a Toshiba Flash Air memory card, SD size, I also have a CF adaptor to   put the card in so I can use it my camera. I  take one image, go to my iphone , set the wi fi on the flash air wi fi, then to to the flash air app to see te image, nothing, I have tried it numberous times with the same results, Just for fun, I put  the same card in my Canon 5D Mark one, and it works. On the Mark one, I went to settings and there is one labeled Communication.,it is set on Print/PTP. there isn't a setting like th is on my Mark 2, I wonder if this is why I can't see the images I take with the wi fi card. Does anyone have any suggestions? The interesting thing is that the Mark 1 is an older camera





Maybe try the alternate setting in Communication dialogue. 

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

there is no "communications" on the Mark 2 camera

@JDH wrote:

there is no "communications" on the Mark 2 camera

Check the instruction manual.  Some Canon DSLRs have a mention in their instruction manuals as to whether or not the camera body Is compatible with an "Eye-Fi" Wi-Fi card, which Canon does not officially support.  

Download the manual, and do a search for the word "Wi-Fi", however it is spelled.  If your camera instruction manuals make no mention of it, then you had a happy accident with the 5D, which I suspect is the case with both bodies.  


The fact that they use CF cards, not SD cards, settles the issue for me.  The camera bodies have no idea what Wi-Fi SD card means.

"The right mouse button is your friend."


I suggest you research whether or not the Toshiba Flash Air is compatible with your cameras.  I think you may have simply had a happy accident with the 5D.  I do not think it is compatible with either camera.


If you are still having questions and problems, ask Toshiba about the Toshiba gear and the Toshiba software.

"The right mouse button is your friend."