cancel
Showing results for 
Search instead for 
Did you mean: 

T3i won't boot with certain SD Cards

noahsilv
Occasional Contributor

Hi guys,

 

Been trying to solve this one for a while.

I recently had an issue with my 600D SD card slot, bent some pins. I replaced the SD card slot. I had ML Installed and running.

Now, after the SD Slot replacement, the camera will not boot with most of my SD cards. However, if I pull the battery, it will boot without an SD card, and with an old 1 gb Transcend car I have.

I have tried three different cards, and it hasn't booted. I formatted them, and even tried installing ML on the cards and making them bootable.

I'm really stumped.

 

Thanks for your help.

7 REPLIES 7

ebiggs1
Forum Elite

What do you mean "boot", either turns on or it doesn't?   It does not even need the card to turn on.  You can not format the SD cards with a computer.  They must be formatted by the camera.

You likely corrupted the firmware if that is what "boot" means.  You need to reinstall it.  Just use Canon's firmware forget the Magic Lantern.

EB
EOS 1DX and 1D Mk IV and several lenses!

noahsilv
Occasional Contributor

The camera will not turn on when some SD cards are inserted. No lights flashing nothing. But then with other SD cards it will turn on normally without any issue. 

noahsilv
Occasional Contributor

Updated the filmware, still no fix

noahsilv
Occasional Contributor
I think I need to disable the Boot Disk Flag

noahsilv
Occasional Contributor

Disabled Bootflags with ML in my Camera, camera now booting with cards but cannot read or format the cards

The cards are write protected.
EB
EOS 1DX and 1D Mk IV and several lenses!

noahsilv
Occasional Contributor

They work with other cameras though.