cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Simultaneous monitoring 5D Mk4

simonjrogers88
Contributor

Hi,

 

I find the simultaneous monitoring on the 5D mk4 refuses to work with some monitors. Does anyone have similar problems or have any idea what might cause it? It works on either the screen or external screen with all the monitors I have tried, but wont display on both on some of them.

 

Thanks in advance.

 

Simon

 

9 REPLIES 9

Waddizzle
Legend

@simonjrogers88 wrote:

Hi,

 

I find the simultaneous monitoring on the 5D mk4 refuses to work with some monitors. Does anyone have similar problems or have any idea what might cause it? It works on either the screen or external screen with all the monitors I have tried, but wont display on both on some of them.

 

Thanks in advance.

 

Simon

 


What does "refuses to work" mean?  Are you getting no HDMI signal display?  

It is most likely caused by a ground loop being create when the HDMI cable is plugged in.  This can be caused by either the cable, or the actual HDMI port not being grounded properly..  By a better HDMI cable, and cross your fingers the cable is ground isolated.

 

I once had a device with multiple HDMI ports.  I connected two HDMI cables to two monitors, and one monitor would go blank.  If I connected either monitor by itself, it worked.  But, if I connected two HDMI devices, one or the other would always blank out.  I bought better cables, instead of the Price Club 2-pack special, and that fixed the problem.

You can also get a ground loop from AC/DC adapters.  What I mean is one device was on battery power, the ground loop goes away.

--------------------------------------------------------
"The right mouse button is your friend."

The signal gets to the external monitor everytime. But when I try and use the simultaneous monitoring feature, on some monitors, I only get the display on the back of the camera. I get the same issue when I try to link the external monitor to a directors monitor via SDI. The same monitors that wont work with the simultaneous display are the same montors that I am unable to connect a further monitor via SDI.

I should add that all of the monitors work with a 5D mk2, so it is certainly an issue with the camera or a compatability issue with certain monitors.

What does "work" mean?  You're not describing your issue very well. What should you be seeing on the displays?

Have you set the video output mode?  If you're getting video output, suitable for a recording device, then your camera is fine.  Look elsewhere.

--------------------------------------------------------
"The right mouse button is your friend."


@simonjrogers88 wrote:

I should add that all of the monitors work with a 5D mk2, so it is certainly an issue with the camera or a compatability issue with certain monitors.


Does it work if everything is running on battery power, if possible?  Still sounds like a potential ground loop issue to me.

--------------------------------------------------------
"The right mouse button is your friend."

simonjrogers88
Contributor
My set up is a HDMI coming from the camera to an external 7 inch monitor. I then want to go from the 7inch to the directors monitor via SDI. My issues are 1 the signal doesn't carry from the 7 inch to the directors monitor and I just get a no signal indicator on screen. I know this is a 5d mk4 issue because when I switch it for a mk2 the signal carries fine and the image is on the directors monitor. Using a 'SmallHD' monitor the signal carries fine with the 5dmk4 too. My other issue is that the simultaneous display also fails when using anything but the 'Small HD' monitor. I get picture on the back of the camera only and no picture on the 7 inch. All of the monitors I've tested so far are able to display the image from the mk4, just not in conjunction with the LCD on the camera.

I seem to keep asking questions, but getting no answers.  Have you checked the camera's HDMI output setting, because the LCD should blank in all modes, except for one?  Is everything runnig on battery, or are there any AC/DC adapters?

 

EOS_5D4_HDMI_Output.Edit.jpg

I still think you're seeing a ground loop.  Good luck.

 

 

 

 

--------------------------------------------------------
"The right mouse button is your friend."

simonjrogers88
Contributor
Everything is on battery. The HDMI output is set to 50i as the monitors are, but I did try auto and 50p too to see if it made a difference, but had no luck. Yes, there is one option where it should display on both the external monitor and the LCD on the back. Thanks for your help, I'll look into the ground loop tomorrow and see if I can find a solution.


@simonjrogers88 wrote:
Everything is on battery. The HDMI output is set to 50i as the monitors are, but I did try auto and 50p too to see if it made a difference, but had no luck. Yes, there is one option where it should display on both the external monitor and the LCD on the back. Thanks for your help, I'll look into the ground loop tomorrow and see if I can find a solution.

I sort of favor Waddizzle's explanation of a ground loop (possibly because I think he may be an electrical engineer and I'm not one). And/or maybe it's a consequence of the 5D4 drawing more power than the 5D2.

Bob
Philadelphia, Pennsylvania USA
Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.