cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Shutter lag problems with canon EOS kiss X4

katephoto
Apprentice

Hi there,

 

I'm new to this forum and photography in general, so please excuse any incorrect terminology or lack of understanding on my part. 

 

My query is related to my Canon EOS kiss X4, which has recently developed a delay between when I press the shutter button and when the camera actually takes the photo, which I believe is termed 'shutter lag.' I have the manual focus on, the self-timer is NOT on, the lighting is good and I can't seem to find any way to fix the problem myself as I have so little knowledge. Just wondering whether anyone has experienced this problem and might have some suggestions? It happens with any lens I try as well.

 

Thank you in advance! 🙂

2 REPLIES 2

Waddizzle
Legend
Legend

@katephotowrote:

Hi there,

 

I'm new to this forum and photography in general, so please excuse any incorrect terminology or lack of understanding on my part. 

 

My query is related to my Canon EOS kiss X4, which has recently developed a delay between when I press the shutter button and when the camera actually takes the photo, which I believe is termed 'shutter lag.' I have the manual focus on, the self-timer is NOT on, the lighting is good and I can't seem to find any way to fix the problem myself as I have so little knowledge. Just wondering whether anyone has experienced this problem and might have some suggestions? It happens with any lens I try as well.

 

Thank you in advance! 🙂


It does sounds like shutter delay is engaged.  Try resetting the camera.

--------------------------------------------------------
"The right mouse button is your friend."

kvbarkley
VIP
VIP

Is the flash up? This can happen if the flash is still charging, though I think it shows a lightning bolt in the viewfinder.

 

You can also set manual focus to eliminate that variable.

Avatar
click here to view the gallery
Announcements