Showing results for 
Show  only  | Search instead for 
Did you mean: 

SL1 display not displaying after taking a photo

Something has strangely started (or stopped) happening on my three year old SL1. I can not seem to get the most recently photographed image to come up on the LCD screen immediately after taking that photo. It certainly used to. I have tried doing a reset, no luck, looked through my Dummies Book, no help. Anyone had this issue or knows where to change the setting to get that function back? I've also gone into the menu and set the display to stay on for 2-8 seconds and still nothing. I'm so used to having it, that after every shutter click I immediately look at the back of the camera. Help – please.

And you've cycled through the various states of the "Info" button?

Philadelphia, Pennsylvania USA

I tried that as well but couldn't toggle as described in the forum, but did stumble upon the answer with the display disable/enable choice in the menu screen. Not sure how I turned it off in the first place though, but it doesn't matter now.


Thanks Bob.

I came here looking for a solution after encountering the same problem.  For me, the answer had nothing to do with camera settings.  I read this message and discovered that the eyepiece on my camera had somehow gotten loose and shifted up just enough to cover the sensor but not enough for me to notice.  I slid it back down with a satisfying click, saw the sensor it had been blocking, and the problem was resolved.

Thank you, thank you, thank you! I’ve had this problem for over a year and tried every setting I could think of. Amazing that it was just that the eyepiece had slipped up slightlly, not enough to notice. I snapped it back down, problem solved. Thank you!!!!!

I have spent most of my day fretting over what I could possibly have done to cause such a malfunction.  Very many thanks. Problem solved. Best. Robert