cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Recording issue

Kahronie
Apprentice
I have a EOS rebel T3 that pretty old but never had any problems with it until yesterday. In the middle of me filming something for my class project the screen start to glitch and the camera froze so i had to remove the battery to completely turn it off and put it back to turn it on. Now everything else works however every time i try to record anything it was glitch up and my camera will freeze. I tried making sure it was charged but idk what else to to everything works normal until i press the record button.
1 ACCEPTED SOLUTION

Kahronie
Apprentice
I’ve used both my full size and Micro sd card and formatted both. I used both lenses i have which are 75-300mm and EFS 18-55 and i still get the glitchy screen idk what else to do

View solution in original post

6 REPLIES 6

kvbarkley
VIP
VIP

Try a new SD card, of the correct speed value, and formatted in the camera.

BurnUnit
Whiz
Whiz

Are you using a full size SD card or a micro SD card with an adapter? Have you formatted the memory card in the camera recently? Ever?

Kahronie
Apprentice
I’ve used both my full size and Micro sd card and formatted both. I used both lenses i have which are 75-300mm and EFS 18-55 and i still get the glitchy screen idk what else to do

Don't use the micro SD. Other than that, you might try calling Canon and they can talk you through some things to try.

Kahronie
Apprentice
The issue haven’t hasn’t been solved ignore that post

Did you low level format?

 

Untitled.jpg

Avatar
click here to view the gallery
Announcements