cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Rebel t3 won't take pictures and now there's a floater when I look in the viewfinder

Quinn124
Apprentice
I've had my camera for 8 months and it just stopped working. I've been in contact with Canon about the camera not taking pictures. They've given me some troubleshooting to try and so far it looks like a lens issue. The last instructions I was given said to remove the lens and clean the metal contacts, which I did. After doing that now I see a floater when I look through the viewfinder. Any ideas?
2 REPLIES 2

TCampbell
Elite
Elite
Does this only show up when you look through the viewfinder? E.g. Does it appear in a photo or in live view mode?

If only in the viewfinder then you may have a bit of dust, etc on the focus screen.

Using a hand-squeeze blower (e.g. A Giotto Rocket Blower, etc. avoid cans of compressed air because they can spray some propellant which leaves a hazy residue.) to gently blow out dust.

The focus screen has a fine textured surface and if you touch the screen you can easily make things worse.
Tim Campbell
5D III, 5D IV, 60Da

ebiggs1
Legend
Legend

What did you use to "clean" the contacts?  If it was a q-tip, you probably got a piece of fuzz from it inside the camera.

You can try a blower, like the Rocket Blower, and see if it removes it.  But remeber there are lots of stuff in there that don't do well after being touched!

 

EB
EOS 1DX and 1D Mk IV and several lenses!
Avatar
click here to view the press release
Announcements