Showing results for 
Show  only  | Search instead for 
Did you mean: 

R5 cannot connect to my Mac via usb cable

Canon EOS R5 cannot connect to my Mac via usb cable. There I tried many cables (Canon, TetherTool, UG) and another Mac but the problem is not solved.
Here are some ways I have tried:
- Try other cables (Canon, TetherTool, UG) 
- Try another Mac
- Turn off all apps
- Update the latest firmware and Utility
- Update the latest MacOS
Sometimes It connected successfully when I had turned off the Dropbox Apps. But now it can't connect no matter what I tried. I tried my Canon 90D and it still connected perfectly.
Please help me!

Not applicable

Make sure Wi-Fi and Bluetooth communications are disabled in the camera. I have heard that Dropbox does interfere with camera communications via USB.

Could you use a memory card reader connected to your computer USB port to transfer files from the memory card to your computer, or do you need to use a Canon utility? I always use a card reader for this purpose. 

Thanks. But I also tried these way and it didn't work. I need Utility for camera liveview.

Not applicable

Have you tried connecting to your computer using Wi-Fi? Maybe that will work instead of the USB cable.  The EOS Utility supports Wi-Fi connections.

WiFi is still fine but the speed  is too low. I can also use C1. But sometime need Utility. Dont know why Canon has left this big problem for a flagship model like R5. In my R5 community, most of members have the same problem.

Not applicable

If you connect the camera to your computer via USB cable, can you see the memory card contents in your computer's file explorer (or whatever the Mac OS calls it)? You should be able to see the camera's card that way.

That would show whether the USB connection is working to the computer.


Hi, I am having the same issue. I have a brand new R5, updated the firmware, updated utility, brand new tether tools cable. If i shut down my mac and turn on again sometimes i get a connection, then I lose it and it comes up with a connection error message. I work with food so need to shoot quickly before it spolis and this weeks jobs have been an absolute nightmare. I never had this issue with my 5d3. Honestly feeling like I've made a huge, very expensive mistake. If you find a solution please coudl you let me know. Thanks so much !!

Greetings louisetatton,

Per your description, you have performed the troubleshooting steps that we would have suggested. Please also check to ensure that Wi-Fi is disabled on the camera prior to connecting the camera to your computer with a USB cable.

Please also check to ensure that there isn't other apps on the computer that are trying to communicate with the camera when attempting to use the EOS Utility software application.

Thank you for your reply. This is ridiculous considering the amount of money I have paid for this camera. Why is such a simple process used by many professionals such an issue. I’ve never had this issue with my 5d mk3. 

I have tried absolutely everything! Everything is turned off! I am so frustrated, this is seriously affecting my work! The camera is connected to my Mac using a brand new tether cable, which is working. all sortware is up to date, no wifi, no bluetooth enabled, no apps. Its beyond comprehension that a your £4K professional camera doesn't work with your own software!! 

Enter for a chance to win