Showing results for 
Show  only  | Search instead for 
Did you mean: 

R3 Freezes - Canon Repaired - Problem Persists!


Preordered the R3 and patiently awaited its arrival. It arrived on time and, wow, what a camera. However, within the first week, I experienced two instances where it froze. No button or dial would respond, however the touch screen still worked. Of course it takes a 'button' to turn it off, so a battery pull is needed to shut it down and then it works again until it freezes. Before anyone asks, it was all Canon gear, R lens included. Different lens were tried, different memory cards, different batteries, etc. What makes it happen is simply having it on for a period of time. You don't even have to be doing anything. So it was still within the period where I could return it to Canon and get another if I chose, but instead, since I had CPS Platinum, giving me an ultrafast turn-around, I opted for Canon repair. They replicated the issue in the shop, fortunately. They reinstalled the firmware and claimed the problem would not replicate. OK, we'll see. I've used it everyday this week with no problem, but all my uses were turn it on, use it for 10 minutes or so, and turn it off. Today I went out for an extended photowalk. I took a break for coffee and a review of the images. So the camera was on from earlier and on for an extended period while reviewing images. I took a break for a minute and when I picked the camera up, boom, frozen again. I was doing absolutely nothing aside from having the camera on. The attached screen shot tells the story. Note the position of the power button, i.e. "OFF" and yet still a picture on the screen. Twice more during the walk, the camera was left on and went to sleep. Twice when I went to wake it up and use it, total black. It would not respond to anything other than a battery pull. So it seems in their haste to do a fast turnaround, they didn't fix the problem. Freezing up seems to affect all recent Canon cameras in the R series, as I read the various forums. Has anyone else experienced this issue and, better yet, had a satisfactory resolution?



Note power "OFF" Image Still On Screen!Note power "OFF" Image Still On Screen!

Canon EOS R3, Canon EOS R5, Canon 5D Mark IV, Canon 7D, Canon EF 14mm f2.8L USM, Canon EF 17-40mm f/4L USM, Canon TS-E 24mm f/3.5L, Canon EF 24-105mm f/4L IS II USM, Canon EF 135mm f/2L USM, Canon EF 180mm f/3.5L Macro USM, Canon EF 100-400mm f/4.5-5.6L IS USM, Canon EF 600mm f/4L IS USM, Canon EF 50mm f/1.4 USM, Canon EF 100mm f/2.8 USM Macro Lens, Canon RF100-500mm F4.5-7.1 L IS USM, Canon RF800mm F11 IS STM

That's great that you have found a fix for your specific body! Unfortunately I have had GPS disabled since day 1 to allow for max available FPS, and I'm still having lock up issues. 


I realize there are several reasons for the camera to freeze-up, but in my case I think I was able to solve it.  I am a back-button focus user.  As you may know, the way you program the back-button focusing is complicated.  Even though you choose functions such as tracking and focus points in the main menu, you can override those functions when you program your back-button focus (for instance, in the main menu you can have the tracking off, but on the back-button you can have it on.  By the way, the way you have to program the back-button is confusing.  There is a sub-menu you have to access by pushing the "info" button.  The manual does not even cover this.)  

My camera was locking up periodically when I was waking it up form sleeping by pressing the back-button.  I believe, in this case, there were too many conflicting instructions being given to the camera (such as "tracking off" in the main menu but ,"tracking on" in the sub-menu of the back-button) and it just locked up.  I solved this problem by waking up the camera by pressing the shutter button half-way.  It's cumbersome, but it has worked for me.  Canon still needs to fix this though.

click here to view the gallery