cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

R3 Anti-Flicker

emdash
Contributor

I shot in a local ice rink the other day and the flicker of the halogens was producing red on my images. I used anti-flicker, but still had the issue. It wasn't all images, but most. In a sports photo group, someone stated to change the anti-flicker to 60hz vs 50hz. I don't see how I can change it unless I set the HF anti-flicker and that changes my shutter speed to whatever I'm setting it to. Obviously, I need my shutter to be faster than 1/50. Any advice on this? I don't want to spend hours post-processing red out of images. This is for still images and not video. I shoot in manual. Lenses: RF 24-70 2.8, EF 70-200 2.8 IS II, EF 400mm 2.8 IS II. This was happening on both my R3 bodies. Shutter varied from 1/320 - 1/1000 except when panning. I tried auto WB and also set the Kelvin. ISO was set to auto and went from 4000-12,800

EDP32491.jpgEDP32492.jpgEDP32507.jpgEDP32536.jpg

16 REPLIES 16

Waddizzle
Legend
Legend

Anything that is automatic is rarely perfect.  You may be dealing with flicker from different light sources that are randomly out of phase with each other, but let’s hope not.

The R3 has a setting that you can enable that allows the camera to adjust the shutter speed slightly to adjust for multiple light sources.  Instead of 1/1000, you might get 1/1024.32 or something.

--------------------------------------------------------
"The right mouse button is your friend."

advrider329
Apprentice

I have had the same issue.  HF anti flicker pulled my shutter too low.  I tried to use manual HF to choose a set the shutter speed, which I ended up around 1271.7.  The issue was this prevented my lens (sigma EF 120-300 2.8) from locking focus.  So I had to use a normal shutter speed.  

Please start a new thread for [your] issue.  Thanks, ahead of time.

--------------------------------------------------------
"The right mouse button is your friend."

ebiggs1
Legend
Legend

" I don't want to spend hours post-processing red out of images."

 

Neither would I. This is one click in Lightroom and it can be applied to all the images at once with just two clicks.

Always shoot Raw format though. You could further balance it but this was just one click in LR for WB. It is slightly underexposed too which doesn't help.

EDP32492.jpg

EB
EOS 1DX and 1D Mk IV and several lenses!

I always shoot RAW and JPEG separately. I know I can post process in LR or PS but would rather figure out how to get it right in camera. Unfortunately I haven’t been back to the rink to shoot, but manually upping shutter with HF anti flicker once I get a baseline may be the best option. I just need to try it. 

ebiggs1
Legend
Legend

"I always shoot RAW..."

 

That's good. I don't see any need to save a jpg but whatever. I personally, and I am not saying it is the best way since time began but, am very comfortable with LR and PS. So I leave WB on average and set WB in post. Raw does not save WB so adjusting it to your liking in post is actually the best way to get it perfect. One of the very few things that does get saved and set in a Raw file is exposure. Raw does get you a huge latitude to adjust exposure but getting it right is a top priority. Your sample is underexposed and that is part of the issue with WB. 

You know that LR has a simple tool for grey scale/WB to automatically correct it? You can apply it to all images with sync.

EB
EOS 1DX and 1D Mk IV and several lenses!

I get it. For wire service, I have to shoot both. Transmit FTP JPEG and save a RAW for possible future commercial use. 

ebiggs1
Legend
Legend

I don't have an R3 but I am sure it has all kinds of new features I simply don't use or even don't want or feel I need.

I guess I am too old school but that's how I shoot sports.

EB
EOS 1DX and 1D Mk IV and several lenses!

Waddizzle
Legend
Legend

What shooting mode and exposure settings are you using?  How many legs of the Exposure Triangle is the camera controlling.  You should not let the camera control more than one leg, regardless if you using Tv, Av, or M.  The wide range of ISO settings you reported are a separate issue from the red tint issue.

If you are shooting indoors, then lighting should almost be constant.  If you are using ISO Auto, I recommend dialing in a set value.  

The red tint is likely being caused by solid state lighting.  The high speed flicker mode should not adjust shutter speed by more than 1%.  There is very little difference between 1/1280 and 1/1271.2.

 

--------------------------------------------------------
"The right mouse button is your friend."
Avatar
click here to view the press release
Announcements