Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problems with a Canon eos T2i


I used my Canon T2i without problems for over a year and I am very pleased with it, but try taking days ago a video after  have been taking pictures in program mode and the camera will lock and no picture could be taken, only appeared one minute later a pattern with vertical lines ... try removing the battery to see if it unlocked and nothing happened, every time I tried to take a photo red light indicates that the camera is processing, (acces lamp), remained continuously lit and not seen any photos. If anyone can help me solve this problem would be very grateful.


Product Expert
Product Expert

Hi Elepeley,


This may be an issue with the memory card.  I recommend that you remove the batter and the memory card.  Then replace the battery without the memory card and turn the camera on.  If the camera function returns to normal except for the "No Memory Card" message, I'd try a different memory card.  If the issue resumes or doesn't go away when the memory card is removed, unfortunately, your camera will require service.  You may click this link for repairs.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Having exact same problem. Tried 3 different memory cards--same. Tried two different batteries-same. When I force restart by removing battery, I push the button to view the live picture via the LCD screen and not the eye piece viewer, the camera locks up that same.
What the hell?!?!?!?

Has anyone been able to resolve this issue?  I am seeing the exact same behavior from the camera.  If there is something we can do to fix this can you please share the solution?





Same problem. Camera function is normal until i take a picture, but if i do the camera freezes up, screem turns black, red light stays on and I am forced to remove the battery to power it off. My firmware is updated, I re-formatted the memory card, bought a new memory card, reset everything to factory settings and nothing seems to work. 



At this point, given everything you have already done to attempt to resolve the issue, your EOS Rebel T2i will need to be examined and repaired by our Factory Service Center.  To start your repair process, you'll need to complete a Repair Request on our website.



Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

forgive me my bad english

i have this problem and a canon service centre took a look at it. They informed me that is would be a mainboard error. It needs to be replaced. Would cost me 250 euro's. 


I took the camera home to think about it. After a few weeks i tried again works fine. I could take pictures again. But when i tried movie it freezes again with the typical distortion on the lcd. Needs to reset by taking out the battery. After a few weeks it got the error again with taking pictures. Nothing helps. Tried to put it away 2 weeks but that did not resolve the problem. 


i tried everything. Firmware, ML, other sd card's, lenses, and then i saw this possible solution for an error 70. Not my error but you never know.


--power down camera and remove battery
--power down HDMI device or powered adapter
--unplug the HDMI from the body, then plug it back in
--power up HDMI device or powered adapter
--insert battery and power up camera


and gues what. It works perfectly. NOT the video function. It's still freezes. But taking pictures is working for months now.

Before it would give the error when i stressed the camera with continuesly shooting at sports or something. Then it became slower en suddenly it would stop and give error 80. And now i can do what i want. It keeps working.


It's worth i try?!




I hope this isn't way too late.  I had the same problem and just successfully fixed it!  I hope you have the same problem.


A part of my old SD card came off and stayed inside the card slot.  It did 2 things.

1. prevent the spring action from catching the card.  I would push in the card and it wouldn't catch.  I had to close the door to keep the card in.  It worked fine for about 2 weeks.

2. Until today.  It would just give me a card error or no card in camera error or a bunch of other laments.  I was very sad!


Then i peeked in with a flashlight and saw a few chunks of blue in the slot.  I managed to pull them out with shaking, canned air and smacking.  Lo and behold, all was well.


Photo of the pieces and a 67mm lens cap for scale.