Showing results for 
Show  only  | Search instead for 
Did you mean: 

Movie files already on computer Question.


This is my 3rd canon Rebel, I starte with a Digital Rebel then went to the 3i and now am onto the 7i.  I got used to allowing windows to simply import my files so I didn't think it could be a problem when I started using the 7i.  I have now corrected my problem and installed the EOS Utility and movies I now download are veiwable but what can I do with the movies I downloaded beffore using the utility as they are still not accessible?



Canon movie utility.jpgJust try to run my file thru the Canon Photo Professional and it said the file had been changed and I needed the EOS Movie Utility but have no knowledge of where to find it.

Well the EOS movie software is a beta and won't run, you just get a message saying it can't connect to your camera.  So far all I can tell is that when you allow Windows to import your MP4 files for some reason it changes them so they are no longer useable.  Now I've used and still own many camera's, SONY, Nikon, Olympus, Kodak, Panasonic and a DJI Drone but only Canon has this issue with importing movie files which seems rediculous.  Yes I know it partly my fault for relying on my past experience with other camera's but why is it only Canon that has and issue?


I tried moving a file back to a memory card and re-downloading it from my camera but once the file is changed it's changed. None of the canon software formats can fix it thou some imported files did show up once I installed the EOS Utility but not all, probably only those imported recently.

If you've edited the video in-camera it may cause some playback problems, though I'd think the Canon software should be able to play it. Be careful when editing video in-camera. When doing so I suspect that you should have the option to save the modified video as a separate, new file and leave the original file intact. Make sure you're not telling the camera to replace the original file with the new, edited file.

Nope, no editing just straight to computer and no access after that.  I have a variety of movie apps, Nero, Adobe, various fileconverters and none of them can fix whatever is wrong with my movie files when imported using Windows. Running Windows 7 Pro.

Are the videos in question all MP4 files? Do they all show the correct file extension (.MP4) after the file name? Were they originally shot as MP4 or MOV or AVCHD or in some other format?

It likely won't make any difference but have you tried opening the earlier unviewable files with Irfanview, VLC Media Player or Media Player Classic? They are all free to download and usually do a good job of playing a wide variety of file formats. I'm guessing these earlier files are no longer on a memory card for further attempts at downloading.

click here to view the gallery