cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Mode Dial Suddenly Stopped Working R5

katgal
Apprentice

Just wondering if anyone else has experienced a sudden failure of the Mode dial after updating to the latest firmware (1.9.0)?  I was in the middle of a wildlife shoot when mine suddenly stopped working a few days ago.  I tried turning off the camera, removing the battery, putting the battery back in and turning the camera back on, but it still wouldn't work.  I've also reset my camera's settings, but it still won't work.  My gut tells me this is a hardware issue and not a software one, but before I go through the trouble of sending it in to Canon for repair, I thought I'd ask to see if anyone else has experienced this issue.  Been using Canon products for over 30 years and have never experienced anything like this.  NOT the time of the year where I want to be sending my camera in for repairs either!

6 REPLIES 6

Hello, katgal! Sorry you are having problems with the R5. I haven't experienced this issue with 1.9 f/w.

Does the mode button still work and if so, can you change modes using the rear dial (Quick control dial 1)? Also, does Quick control dial 2 (around the mode button) still change ISO?

Newton

EOS R5, R6, R6II. RF 15-35 f/2.8L, 50mm f/1.2L, 85mm f/1.2L, 100mm f/2.8L Macro, 100-400mm, 100-500mm L, 1.4X.

The Mode button still does work in that if I press it, it brings up the the Mode menu on both the top display and on the rear display.  However, the dial around the Mode button doesn't let me change the Mode setting.  That same dial around the Mode button doesn't allow me to change ISO either.  

Canon has replied to my email and has suggested a number of things to try.  I've already tried a couple of them and it still won't work.  I'm beginning to believe this is a mechanical issue that'll require Canon to repair it.

Waddizzle
Legend
Legend

I’m sorry to hear you’re having issues with the camera.  

This issue is a new one.  I think it is unlikely that the issue is related to the firmware update.  Many other users have installed the update without reporting a similar issue.

The symptoms you are describing sound consistent with the [LOCk] function being enabled.  When you attempt to use the control does an “L” appear in the EVF?

--------------------------------------------------------
"The right mouse button is your friend."

It's definitely not locked.  I've tried all of the fixes that Canon support has suggested to me and it's now clearly a hardware issue.  I'll just have to schedule time for the camera to be sent in for service when it's convenient.  Got too much wildlife to photograph between now and early June, and having this one dial go down isn't affecting the overall performance of the camera.  It's more of an aggravation simply knowing I'll have to send it in for servicing.  

marrap
Apprentice

I have the same issue.  It occurred before I had updated to 1.9.0.   

shadowsports
Legend
Legend

Greetings,

Sorry to hear about these main dial failures.  Canon can repair.  Its usually  a complete top assembly.  

Visit MyCanon to initiate the repair in the US and Canon Global if in another region.

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It
Avatar
click here to view the press release
Announcements