Showing results for 
Show  only  | Search instead for 
Did you mean: 

Microphone for shooting video on Rebel T3i


I have a Rebel T3i that I would like to shoot video with. I need to use a lav mic based on the environment I am shooting in. I have a wireless mic with a receiver that attaches to the top of the camera. I did a few trial runs in my office of me & others talking, and when I played them back on the computer, there is a lot of white noise in the background. I tried a different mic that was not wireless, and got the same thing. One of the mics I tried had an on/off option, and I actually had it off when I first started recording...I turned it on a few seconds later, and when I played the clip back on the computer, the white noise was there for both of them. 


I did not try using just the camera's internal microphone, as I know it will not work (I work for a construction company, and we need to interview people out on the jobsite...very noisy). 


Please let me know if there are ways to get rid of this noise...wheter it's a camera setting or a new microphone. Does Canon make a compatible mic? 


Help appreciated -- thank you!



Hello lpatterson,

When recording with an external microphone on the EOS Rebel T3i, the internal microphone cuts out- so we can eliminate that as a source of the noise. 

Let's say you you use the wireless lav, because I assume that's the most convenient one for you.  The camera has a few different audio settings: Auto, Manual, Disable.  Your camera is probably in the Auto mode right now.  I would advise connecting the microphone, turning the camera on, going into the Menu and look for the Sound Recording option- it's located under the second Movie Shootings setup option. 

The first and easiest settings to try is called Wind filter.  This essentially attenuates the microphone to be less sensitive, think about the sound it would make if you heard the wind noise getting picked up- this attempts to calm that effect down a bit.  I'd try this first before going on to the steps below, as it'd be great for you if this solved it quickly! 

Assuming that doesn't work, you should also see an option to change it over to Manual mode.  This will allow you to view a dB meter which should respond to the lav mic and it picks up sound.  If you're in an area which is loud, it's probably distorting the mic because it's too sensitive- so I am suggesting adjusting it down slightly. 

Select [Rec. level] and look at the level meter while pressing the < / > keys to adjust the sound recording level.  While looking at the peak hold indicator (approx. 3 sec.), adjust so that the level meter only sometimes lights up the "12" (-12 dB) mark on the right for the loudest sounds.  If it exceeds "0" , the sound will be distorted. 

Canon doesn't make a dedicated external microphone for the EOS Rebel T3i, but we do have some guidelines to help you pick out a microphone too, assuming that neither of the above work and you wanted to try a different microphone.

You can use a commercially available external that is equipped with a stereo mini plug whose size is 3.5 mm in diameter with the camera.


  • It is possible to use a that supports plug-in power (which is supplied from a camera to the ) because the EOS REBEL T3i/EOS 600D is compatible with plug-in power.
  • It is possible to use a condenser . However, it is not possible to use a condenser that requires phantom power (which is supplied from external power equipment to the ).
  • It is not possible to use a dynamic .
  • The impedance of the that can be used with the camera is around 200 O to 2KO.

Compatibility of

Condenser Plug-in power(supplied from a recorder (camera) to the )Battery cell(supplied from a battery cell to the )Phantom power(supplied from external power equipment to the )
Dynamic Generating power by itself(Power is not required for the including the used for Karaoke)

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.