Showing results for 
Show  only  | Search instead for 
Did you mean: 

I went to update my firmware of 70D suddenly it stuck


I went to update my firmware of 70D suddenly it stuck then i tried to reinstall the battery it didnt helped. Now i m stuck the firmware update menu what should i do now



Disconnecting power is the LAST thing you should have done. Interrupting a firmware update likely has crippled your camera. This is something requiring Canon's service assistance, if even they can salvage it.

Can u tell me how can i talk with them at online

If you're in the United States, we encourage you to call our support team at 1-800-OK-CANON (1-800-652-2666).  They're available weekdays and Saturdays.  You can also find additional support options when you register your camera as part of your MyCanon account.

If you live elsewhere, you'll need to contact the Canon company that serves your part of the world.  You can find them by clicking here and then clicking on the map to select your region or country.

Hope this helps!

Not applicable

Assuming a Windows computer was used to download the file, open the .zip file and extract the .fir file to the root of the SD card. Put it in the camera and start the firmware update process again. Are you positive that you downloaded the correct firmware file for the EOS 70D camera?

You're assuming the camera is not bricked because of the interruption of the first update, either by a glitch or by battery dying/removal.


if i remove the memory card it says update file cannot be found . if insert the memory file it stucked at the 36% then it says check the memory card then reload the battery . i bring another memory card and tried the process it didnt helped



Diagnosis is straight forward.  If you don't have a memory card installed, does the camera start normally, or does it display the firmware update menu only?  You indicated you have tried 2 different cards with the same result and the camera will not proceed past 36%.

If the firmware update menu is all that displays, the camera is bricked and it's existing FW is corrupt.  The device will need to be sent to canon for service.  I'm sorry, but this is not something that can be resolved via chat, with the EOS Utility or remotely.  Please open a support case and prepare to send your camera in for repair.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th