cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

I am getting error 99 on my camera - Canon EOS Rebel XSi

anilkris
Apprentice

This camera is used for the past 4 years. Never faced any isses. Suddently started getting the error 99, "Shooting not possible. Turn the power switch to <OFF> and <ON> again or re-install the battery".

 

the following are tried:

 

Removed the battery, fully charged it again

Changed the SD Card

Changed the Lens

Removed the battery, lens and SD card and kept the camera idle for 20 minutes just clicked with out SD card.

 

No changes. 

 

these I did not try

 

Change the battery pack to see if it helps, no back up battery with me

Did not update the firmware since I bought the camera in 2009. I do no know if it is available for my model.

 

Any help/suggestions are welcome!!

 

regards

Anil Krishnan

5 REPLIES 5

Naomi
Enthusiast

Hello anilkris!

 

You might find your solution via the following forum post.  Please use the following link:

 

http://forums.usa.canon.com/t5/EOS-Rebel/Error-99/m-p/21711/highlight/true#M817

 

This link should resolve the Error 99 issue experienced by Canon EOS Rebel XS, Canon EOS Rebel XSi, and many other camera models.

 

Hope this helps!

ebiggs1
Legend

"Change the battery pack to see if it helps, no back up battery with me"

 

You need a different, preferably new, battery as the error may be the battery. Also the battery must be out of the camera for a long time, a few hours or so.

 

"Did not update the firmware since I bought the camera in 2009."<-----This is not the error.

 

 

You must clean the lens contacts. And, or, try a different lens. While you are at it get a brand new high quality SD card.

EB
EOS 1DX and 1D Mk IV and several lenses!

My experience with error 99 is that it seems related to a component trying to draw more current than it should. To prevent that from happening, which could damage the component either from heat or overstressing a mechanical part the camera shuts down & gives the error code. A weak battery can easily be at fault but so can a lot of other things.

"A skill is developed through constant practice with a passion to improve, not bought."

amfoto1
Whiz

I agree... the first thing you should try is a fresh battery. A four year old battery might be on it's last legs (probably depends upon how many times it's been recharged.... and how deeply it was discharged in between charges).

 

If possible, it would be good to also try a different charger. Sometimes they go bad.

 

Does your camera have a separate replaceable date/time battery? If so, it might be a good idea to replace that, too. Those types of batteries usually have roughly a five year lifespan.

 

Wouldn't hurt to update the firmware. If' it's never been done, very likely there is a newer version. Even if it's not an update, it might be a good idea to reinstall it.

 

HOWEVER, before you attempt to install a firmware update, you must have a reliable, fully charged battery. You don't want to have a camera shut down halfway through a firmware installation. That's almost guaranteed to "brick" the camera. So sort out the battery first, to be certain you don't have problems there.

 

The reason for replacing the firmware is it might have become corrupted. It's essentially an operating system for the camera, which is essentially a computer... and "stuff" happens, as we all know, to computer operating systems! Sometimes a reinstall or update will correct problems in the software.

 

Canon's and ebiggs instructions above about "rebooting" the camera are a good idea too. In fact that's the first thing I'd try, since you don't need anything to do it. The reason you "reboot" is to clear any lost data strings from the memory, that might be interfering with the camera's operation. Again, it's a lot like a computer.

 

A little more about rebooting the camera... If your camera has a date/time battery, in addition to the main, rechargeable... remove both of them. Rather than letting the camera sit, another method is to turn the camera on without any batteries, and press the shutter release button once. It won't fire, of course. But this should drain any remaining charge from the circuit immediately and is faster than waiting for the residual charge to drain off slowly.

 

Once you have done this (or let the camera sit for 20 minutes or several hours without the battery), go into the menu and see if the date/time needs to be reset. If so, you got a proper reboot.... If not, try again.

 

In addition to trying a different memory card, always formatted in the camera, also inspect the slot the card fits into carefully. Look at it with a flash light, to see if anything looks damaged, shorted out or if there is any obstruction. Probably not something you can fix yourself, if there is a problem.

 

I agree about cleaning the lens to camera contacts. I use a few drops of isopropyl alcohol on a clean, lint free cloth. That's to remove any oils (finger oils, or lubricating oils from inside the lens or camera). Just keep off the mirror in the camera and the lens optics.

 

You also might use the same to clean the battery contacts both on the battery and on the charger (unplug it) and inside the camera. Wipe down the date/time battery, too.

 

None of the above is certain to fix the problem, but all are fairly easy and free or relatively inexpensive to try.

 

If none of the above works, then send the camera in to Canon and have it checked.

 

***********
Alan Myers

San Jose, Calif., USA
"Walk softly and carry a big lens."
GEAR: 5DII, 7D(x2), 50D(x3), some other cameras, various lenses & accessories
FLICKR & PRINTROOM 

 





 

Thanks for the responses from each of you!

 

Today I have taken the camera to 'Hunt's' shop very fameous canon dealer in Boston, MA. The tried with a new battery and also different lens, I get the same issue. 

 

The camera is in allow clik without SD card and it error even without a lens. So I am ruling out the lens, battery- old & new, camera contacts with lens(I cleaned it by myself & Even the canon expert in the shop). 

 

I have decided to send it to Canon service center in NJ. I have to pay 190$ and then ship it to them. I will have my fingures crossed. Lets us see

 

regards

Anil Krishnan

Announcements
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
10/14/2022: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
09/19/2022: New firmware version 1.0.4.1 is available for EOS C70
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!