cancel
Showing results for 
Search instead for 
Did you mean: 

Help!! Broken Autofocus

mdavies18
Contributor

I have a canon rebel. 

Recently the autofocus stopped working completely. The lens will zoom in and out and eventually give up trying to focus, I can't take a photo at all!

The camera has had no damage as I am aware.

I have tried more than one lens and it is still the same problem. So im assuming its the main body.

I've cleaned the sensors mirror contacts etc and done a factory reset.

The camera works fine in Manual focus AND if its set to live view mode. If its set to autofocus through the viewfinder it will not work.

What could be wrong?! Any suggestions on what to do?! I'm so bummed as I have only had the camera a year and a half.

Canon estimate for repair was near $300....I have no warranty on the camera 

Please help!

11 REPLIES 11

JacobT
Product Expert
Product Expert

Greetings mdavies18,

Per your description, you have performed the troubleshooting steps that we would have recommended. You're able to confirm that auto focus works when shooting through the Live View function which does use a different auto focusing system than the one used by the viewfinder.

I'm sorry but the next step would be to suggest to send the EOS Rebel camera to our facility for repair. Please complete the repair request online and send in your camera body to our facility. Repairs do include a 6 month repair warranty on the repair that is carried out on the equipment.

Alternatively, you may check to see if you may be eligible for the Canon Upgrade Program.

The Canon Upgrade Program option allows you to replace your current camera with a new or refurbished Canon camera at a discounted price. If you would like to see if you are eligible for the Canon Upgrade Program, please call our Sales Department at 1-866-443-8002 from Monday - Saturday between 9:00 am to 9:00 pm ET. Be sure to have your serial number for your camera available at the time of your call.

Thankyou for the response!

I will look into that 

Tronhard
Authority

This is a rather desperate suggestion, but it might be worth checking that your camera is not set to macro mode, either on the dial or in the menus.  I came across a similar situation some time ago, and the camera was desperately looking for some very close-up object to focus on before giving up in disgust.


cheers, TREVOR

Professional photographer, engineer and educator since 1980

"All the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris
"A good swordsman is more important than a good sword" Amit Kalantri
Technique will always Outlast Tech - Me

Thankyou for the reply. I will double check, but another thing I've done is a factory reset, would this not set everything as it should be? 

Anthony1528
Apprentice

1 – Remove and remount the lens. This is probably the most common reason that your camera won't focus. 
2 – Check the AF/M switch on the lens. 
3 – Aim your focus point at an area of contrast. 
4 – Use the center focus point. 
5 – Make sure you aren't too close. 
6 – It's too dark.

Myjdfaccount

Tried all these already but thanks for the reply!

MikeSowsun
Authority

Check the AF sensor “field lens” under the mirror for excess dirt or dust, or physical damage. It is located at the bottom of the mirror box under the mirror. Gently lift the mirror to see it.  If it is dirty or damaged, it could be the problem. 

When you lift the main mirror, you should also see the “secondary” or “sub-mirror” swing out of the way. Check to see that the “sub-mirror”, under the main mirror,  is working properly and is not missing or damaged. 


BC2D6CEA-638A-4142-84FD-D64A97EF2701.jpeg

E353930E-3818-427A-94B4-E33F82B3FB6F.jpeg

In order for the AF to work, the light must pass through the main mirror, reflect off the secondary mirror, and then enter the “field lens”. If the light path is degraded along the way due to dirt or misalignment, your AF is going to be compromised.

6FDC09CB-29DE-44E1-94DE-A8E8D71E1CC6.jpeg

Mike Sowsun
80D, 5D Mk III

Thankyou, I will try this. How do you suggest I lift the mirror? Like with a q-tip?

A Q-tip would work, but try not to leave in fibres behind. You can also just use a finger on the edge of the mirror. 

Mike Sowsun
80D, 5D Mk III
Announcements
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM