Showing results for 
Show  only  | Search instead for 
Did you mean: 

Had solid red light for a while after turning off T3i


Quick question about my new camera. I took some video with my new t3i today and something sort of wierd happened that I cannot find any threads about. I stopped recording turned the knob back to P mode and switched it off all pretty quick. I removed the lens and noticed the red led on the back was still lit up solid (not blinking at all) so i thought maybe it was still writing the video to the card i am not sure how long that takes or how it works.

So i decided to wait for it to go off and it never did after probably a 1 1/2 mins it was still lit solid. I tried to turn the camera back in and nothing happened so i switched it back off (light still lit) and pulled the battery. Put the battery back in and it turned on fine. I checked the card for the video and it was there so it didnt seem to be a curruption issue while writing. I tested video again a little later and also took some test photos and didnt have the problem again so far.

Has anyone else encountered this or is it normal? I was only about to find threads about the light blinking not being solid red. I should mention that I do hve magic lantern (the stable build not any nightlies) installed on that card but was not actively doing anything with it at the time but i know that may not matter. Also the card is a fairly good one, (sandisk extreme pro 95/mbs) and I do format it using only the camera. (Low level format while keeping magic lantern.)

I am not too worried about it at this moment just curious if anyone knows what it could of been. Also I never got any error codes either.

Thanks! 🙂

While it's not "normal", I see you're using Magic Lantern ... so all bets are off. While they are pretty good, they do warn that there may be bugs. If you read their cautions, you'll notice they warn that if you experience any strange problems while using their firmware you should eject the battery (that's the only thing that truly cuts power because the battery merely sends a "signal" to tell the camera to turn off... it doesn't actually "cut" power.

I'm glad to read there was no corruption and that it hasn't happened again.

Normally the red light indicates the camera is talking to the memory card and while the camera does have a "buffer" and wants to finish writing any in-camera data to the card, it should not take nearly that long to complete that operation. I suspect you found a bug in Magic Lantern.

With that said... Magic Lantern firmware is generally pretty cool. It's an open-source community and no other camera maker has a community of people making anything like it.
Tim Campbell
5D III, 5D IV, 60Da

The only thing i can think could of maybe caused it to crash like that aside from just a random fluke is because I switched the mode knob from video to P pretty fast right as I switched it off. Maybe it tried to switch modes in the firmware at the same time it was trying to go through shutdown and crashed.

I agree with Tim and guess it is a ML issue.  And another reason I don't use it or recommend anyone else use it.

EOS 1DX and 1D Mk IV and less lenses then before!

I have t3i and experiencing same issue with the solid red light. It almost feels like it freezes camera. I have done low formating and reset all the setting in the camera but same issue still there. I try to take a photo and its all freezes and does not save it. My SD card is. Sony 32 gb. I have used it before and it worked with no problem. Not sure what caused the red light. I have also tried other SD cards but the issues stays the same. Please help.

Are you using ML, also?  If ML causes a major problem it turns the camera into a brick.  It can not be undone. It has to go to Canon for service.

If you are not using ML and have tried all the easy stiff and recommended stuff, your camera probably needs service too.

Call 1 (800) 652-2666

EOS 1DX and 1D Mk IV and less lenses then before!

Thank you for the message. Canon does not do service to this model any longer, camera is still like sad that it stoped working.

Are you using ML, also? 


You did not answer.

EOS 1DX and 1D Mk IV and less lenses then before!

You should spell out "Magic Lantern"


Have you tried a new card and formatted it in the camera? It sounds like your card is fragmented and it takes a long time to write your images.

No, I have never used ML, I have tried 2 different SD cards ( that were used before without any issues). And I formatted them both in the camera and did settings reset, as well as tried different lenses. Nothing helped. Canon says they no longer to repairs on this model.
National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th