cancel
Showing results for 
Search instead for 
Did you mean: 

EOS utility does not start

paulogcarvalho
Contributor

Running under W7, EOS Utility does not start anymore. Worked properly for a few monthes. Previously had some problems with wifi connection, corrected after unistalling and installing again. Now it wont start anymore (after a W7 update???) . Works fine in another computer running W7. Any suggestions?

1 ACCEPTED SOLUTION

paulogcarvalho
Contributor

Thanks to all. The problem was not a W7 update, but AVG 2015 antivirus. Windows restore function was blocked by the antivirus. When antivirus was removed to allow Windows Restore to work probperly, EOS utility poped up and worked fine. Now I have to stop antivirus when using EOS utility. I will notify the AV maker to find a solution.

 

PS: With the nice help of AVG support, I have created some exceptions (files that are not checked by AVG) and included  the EOS Utility in this exception list. It is now working OK!

View solution in original post

16 REPLIES 16

jazzman1
Rising Star

Have you tried a "system restore", using a restore point when it worked.  You could also try uninstalling the windows update you think may have caused the problem.

ebiggs1
Legend

"Any suggestions?"

 

Yes.

Uninstall it and reinstall it, agin.

Did you do any other upgrades or additions to the computer recently?  Anything?

EB
EOS 1DX and 1D Mk IV and several lenses!

PaulSoebekti
Enthusiast

EOS utility is initiated when windows starts up. When the 'link' is broken or corrupted the utility can not 'sense' the presence of the connected camera.

Assuming that you have the original software discs, uninstall EOS Utility from the control panel, reboot, and re-install the program. Otherwise, download the EOS Digital Solution Disc Software from Canon, supply your camera's serial number (gleaned from a pictures exif) and reinstall. Once installed update to its latest version.

Hope this helps.

 

Paul

paulogcarvalho
Contributor

Thanks to all. The problem was not a W7 update, but AVG 2015 antivirus. Windows restore function was blocked by the antivirus. When antivirus was removed to allow Windows Restore to work probperly, EOS utility poped up and worked fine. Now I have to stop antivirus when using EOS utility. I will notify the AV maker to find a solution.

 

PS: With the nice help of AVG support, I have created some exceptions (files that are not checked by AVG) and included  the EOS Utility in this exception list. It is now working OK!


@paulogcarvalho wrote:

Thanks to all. The problem was not a W7 update, but AVG 2015 antivirus. Windows restore function was blocked by the antivirus.


Glad you're up and running. 

 

I always...ALWAYS...disable my anti-virus program when using Windows system restore.  I also create a full Windows OS Image backup every month after getting our monthly microsoft updates.  That way if all else fails fixing any camera software issue, I can easily restore my OS (and camera software & programs) back to how it was before disaster hit.  Sometimes windows system restore will fail for some reason or the other, most times from anti-virus protection being active.  I cannot stress enough, the importance of an OS (operating system)  Full image backup.

My EOS Utility, both 2 and 3, works when I disable AVG. But exclusion of the .exe or the entire EOS Utility folder do not help. So now I am looking for some other AniVirus. Any recommendations? Until now I have been satisfied with AVG.

 

Have Win 7 and Win 8.


@mad_marten wrote:

 now I am looking for some other AniVirus. Any recommendations?

 

Have Win 7 and Win 8.


I use Avast, it's free, and it does'nt hamper any of my Canon software.  I'm surprised AVG would do that.


@mad_marten wrote:

My EOS Utility, both 2 and 3, works when I disable AVG.

 

Have Win 7 and Win 8.


Are you saying you have EOS Utility 2 & 3 installed on the same Pc???

Yes, when I downloaded EOS Utility from Canon support pages i got new releases of 2 and 3 and both are running (with AVG disabled) on the same computer.

Announcements
09/19/2022: New firmware version 1.0.4.1 is available for EOS C70
08/31/2022: New firmware version 1.1.1 is available forRF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!