cancel
Showing results for 
Search instead for 
Did you mean: 

EOS Utility 3 won't launch on Windows 10 Anymore

anita1
New Contributor

I have just recently downloaded EOS utility 3 on my Windows 10 and I could only transfer photos using my camera as access point. But now the program won't even launch. Or it would launch only once every time I turn on my laptop.

5 REPLIES 5

Tim
Respected Contributor

Hello anita1, 

We are sorry this is the case.  We recommend uninstalling the application from your computer and rebooting.  Then, reinstall the application directly from the web site.  

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

anita1
New Contributor

The app launches now but it won't connect either through wifi or camera access point.

Hello!

So that the Community can help you better, we will need to know exactly what model camera you're using and any error messages you're seeing.

Any other details you'd like to give will only help the Community better understand your issue!

If you're in the United States, and this is an urgent support need, please click HERE to enter your product information and discover your support options. 

If you're outside of the USA, please click HERE to find support options in your country.

Thanks and have a great day!

shadowsports
Esteemed Contributor

@Anita1

Please be specific when you answer Stephen's questions.

 

Your body is? 

Version of EOS Utility 3 you are using?

Build of Windows 10 (1809, 1903, 1909) etc?

 

3rd party antivirus or security applications can cause connection issues. 

 

Thanks

~Rick
Bay Area - CA
~6D2(v1.1.0) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6


@anita1 wrote:

The app launches now but it won't connect either through wifi or camera access point.


What camera are you using?  

Does your PC use "Intel Inside" hardware?  

How old is your PC?  Did the PC come with Windows 10 installed, or is it an upgrade from Windows 7/8?

How many USB ports do you have?

 

Why would the app launch if the camera won't connect?  The only reason the EOS Utility app auto launches is because the camera has connected and been recognized the Canon EOS Launcher Service.  

 

I suggest that you do a complete removal of the entire EOS Utility Software Suite, and do a complete re-installation.  Windows has settings that allow you to specify actions that are taken when you connect USB devices.  

 

Canon_EOSU_Startup.png

 

DO NOT ADJUST these settings in Windows.  Leave them at their defaults.  The EOS Launcher Service should be used to manage the startup behavior of the EOS Utility, instead.

------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."