Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Rebel XS Issues with Memory Cards

Hello! I have had my EOS Rebel XS for over a decade. I have never had any issues with it until recently where it won't work with my memory cards. I have primarily used a Transcend 16 GB card and a SanDisk Ultra 16 GB card. Recently, I ran out of space and went to pick up a new one. I was advised to purchase a SanDisk micro with an adapter by someone at the store (which I've learned recently is mistake #1). The camera immediately would take a few photos and then prompted me to format. After some quick searching, I realized this was a mistake and tossed it. I then purchased a SanDisk Ultra 32GB from Amazon (now learning this is mistake #2). I have formatted the two new cards extensively, cleared all camera settings, etc. Following all of this, I cleared some space on my original memory cards and now they allow me to take photos for 10-15 minutes, but are also giving me the same error saying 'card not formatted with this camera.'
Did I cause damage to the camera with the adapter card? Is there a way to fix this?



It might be time for a couple of new 16Gb cards.

Steve Thomas