cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Rebel T6i won't connect via Wi-Fi to Google Pixel 5

asdsixty9
Contributor

I'm using a Google Pixel 5 and recently updated to Android 12.  Now, my phone will no longer connect (and stay connected) to the camera WiFi  It seems that since the phone detects 'no internet' for the camera WiFi signal, it now automatically looks for a different WiFi signal to connect to.  This wan't a problem prior to Android 12.  This seems to be a phone/ connection issue, but i'm wondering if anyone knows how to correct this?  I haven't seen an obvious way to correct this through the phone settings yet.  I'm using a EOS Rebel T6i with the latest firmware. 

Thanks!

1 ACCEPTED SOLUTION

Greetings,

I can confirm this is working on Pixel4 and Pixel6 Android 12.

 

Tested both Wifi and BT individually.  No issues with either device remaining connected.  The camera conected to my P4 as it did with 11.  I then cleared the previous profile settings on the camera.  The new phone connected immediately.  I tested settings, image transfer and live view (shooting).

 

Canon App version 2.8.10.20 (build 1246)

Android 12 v12(SD1A.201817.036)

 

Glad you got it working.

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

View solution in original post

16 REPLIES 16

@Waddizzle, what do you mean "Bluetooth. Try it."?  My phone and camera are paired for bluetooth; the problem is that the phone won't stay connected to the camera's wifi. It connects to the camera, disconnects in a couple of seconds and reconnects to a wifi network with internet access.

 

EDIT: Some cameras can transfer by BT. Is that what you mean?  Unfortunately, the G5Xm2 does not - only wifi.

Leonetti
Apprentice

I think I found out the reason I was having issues, I had the google fi VPN on and when I turned that off it solved my connection issues, so that's a possibility.

If you were here, I would buy you a beer!  I've been working on this all weekend.  That did the trick!  

Zander013
Contributor

hi im having issues with my EOS R50, im not able to connect to it on my pixel 7 running android 14. bluetooth is fine but when i attempt to connect over wifi to transfer pictures it justs give me connection failed. ive run through all the tips on here to attempt to fix everything short of having to reformat my phone which i feel is a little unnecessary.

 

ive run on the latest cannon firmware for the camera and the cannon connect app and still unable to wifi connect for any of the features. any help would be greatly appriecated.

Hi Zander013,

When the connection drops are any error messages showing on the camera LCD, and if it does show an error message what does it say word for word?

One thing to double check is if you have a VPN on your phone. When you connect the camera and phone through Bluetooth they switch to a wifi connection when you start importing photos/videos or when you start to remotely control the camera. If you have a VPN on your phone that can cause issues with the camera and phone connecting.

1000163576.png

Hi thank for the reply this is the error I get when attempting to connect to my camera. I don't have any vpn installed or running on my phone currently or have ever used one on this phone.

 

I've been able to somewhat work around it by taking my phone and directly plugging into my camera but I'd rather be able to directly send stuff to my phone for editing or emailing off to others to see without having to plug in every time.  

j2323
Apprentice

I was having this issue on my R8, wouldn't connect to Pixel 6 on Android 14.

I remember there was a security update for android a ways back that broke a lot of bluetooth connectivity with some devices, basically the OS locked out certain bluetooth functions that would have allowed it to joint the network but don't quote me on it.

Anyways, got it to work by going to the Wifi Connections menu page (purple), and then Advanced Connection > Connect to smartphone > Add a device to connect to > next > Camera access point mode > Manual Connection.

You have to manually connect to the Camera's SSID from the phone, don't use bluetooth at all for any of this or it won't work.

I created a custom SSID on the camera and set it to no encryption. On the phone I joined that network I just created and then opened Camera Connect and it worked.

This happened before once with my G7XII but Google eventually pushed out a patch that fixed that issue, looks like it's happening all over again. It's the camera firmware prioritizing bluetooth connection, presumably in the hope of simplifying the user experience, however the function calls are interpreted as a security threat by Google so it's locked out in the OS.

Avatar
click here to view the gallery
Announcements