cancel
Showing results for 
Search instead for 
Did you mean: 

EOS Rebel T3i suddenly not recognized by computer?

abc123
Apprentice

Suddenly my computer wont recognize my camera as a device, it's like it's not even plugged in at all. 
It's not the USB, it's not the cord, it's not the computers because I've tried different ones of bothn tems,. I turn on the camera after plugging it in and it just turns on as if to take a photo.

I've tried unplugging it, resetting the computer, turning it off and on and nothing worksl.

The EOS utility download doesn't work.
I've tried it on Windows 7 and Windows Vista

7 REPLIES 7

maramada
Apprentice

I have the same camera, same issue. If you get it resolved, please post solution! Thanks

Mykolas
Authority

Hi abc123!

 

Thanks for posting.

 

When the camera is connected and powered on, do you hear a noise from the computer indicating a connection has been made?

 

Does the computer show the camera at all in the Device Manager?  To check, click the Start button, type Device Manager and press Enter.

 

Is your computer a laptop?

 

What USB port on the computer are you connecting it to?

 

If this is a time sensitive-matter, additional support options are available at Contact Us.

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

abc123
Apprentice
...LIKE I SAID wont recognize my camera as a device, it's like it's not even plugged in at all.
It's not the USB, it's not the cord, it's not the computers because I've tried different ones of bothn tems,.

Ive tried it on laptops and desktop. ON all usb. DOES NOT RECOGNIZE THAT A DEVICE IS PLUGGED IN, understand?

abc123
Apprentice
Im computer savvy so trust when i say NOT RECOGNIZE DEVICE it means NO CHIME bevause that happens whrn a device is recognize. ITs not the drivers, its not the multiple USB OR computers/laptops used. ANd its not my method of plugging the camera in and turning it on. IDK what it is.

Hi abc123, I recommend contacting our Technical Support Department for assistance with this. For contact options, please see this site: http://www.usa.canon.com/cusa/consumer/standard_display/contact_us_consumer
Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


@abc123 wrote:
Im computer savvy so trust when i say NOT RECOGNIZE DEVICE it means NO CHIME bevause that happens whrn a device is recognize. ITs not the drivers, its not the multiple USB OR computers/laptops used. ANd its not my method of plugging the camera in and turning it on. IDK what it is.

A computer savvy person still using Windows Vista is almost an oxymoron.

Bob
Philadelphia, Pennsylvania USA

ndudiuk
Apprentice

I had the same issue. I removed an old driver and installed a new one. Voilá, it works now !

Announcements