Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R7 "Firmware cannot be downgraded"


I downloaded the new EOS utility and the 1.3 firmware. When I use Canon Conn etc on my Mac to connect via wi-fi, the connection seems solid. I get to browse for and select firmware 1.3 to install over 1.2 But every time I get the message that the firmware cannot be downgraded..... Please advise.


While downgrading firmware is possible, Its not recommended.  Best case it works, worst case, you brick your camera.  What's wrong with v1.3.0?

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~6D2 (v1.1.1) Retired ~EF Trinity, others ~DxO PhotoLab Elite ~Windows10/11 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

Right, but I’m not downgrading the firmware. I’m trying to install version 1.3. Version 1.2 is what is on the camera.

I'm not sure what's up with Canon Connect and your WiFi try 🙂 I would put the FIR file on a card and do it in camera. If that fails, you may need to contact Canon Support.



Sorry, your threads title appeared to indicate you wanted to go backwards.  Maybe you meant "downloaded" instead of "downgraded"?

Maybe this will help.

Start by downloading firmware v1.3.0 for MAC

Use a fully charged battery in the camera

Use a full size memory card, freshly formatted in the camera

Click on the firmware file it should mount on your desktop

If it doesn't, open Finder preferences and check the Hard Disks box

Try the file again, this time it should open and mount.

Open the folder, look for (file) EOSR7130.FIR

Copy that file to the root (top level folder) on the memory card

Now perform the firmware update using the camera's LCD and rear buttons to navigate.

Once the firmware update is started, do not press any buttons or touch the camera until its complete

Note: while you might be tempted to use the EOS Utility or Camera connect app to upgrade, the safest way to update firmware is directly from the camera's SD card.  I'm just pointing this out, the choice is yours.  

Instructions are also included with the download.  If you have any question, just ask.  Anyone here can help.

Let us know how it goes. 😀


Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~6D2 (v1.1.1) Retired ~EF Trinity, others ~DxO PhotoLab Elite ~Windows10/11 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It


Hi hahacky

Did you get this sorted out? Having a very similar problem here trying to install 1.3 firmware to Canon R7 with 1.2 firmware.

I get the same error using Camera Connect on IOS and when using EOS Utility on Windows. 

To those who replied earlier, we are not trying to downgrade the firmware ... the thread title "Firmware cannot be downgraded" is the error message we are getting, even though we are upgrading frimware.

Yes, agree. Not sure why people are telling me what I meant to say when I am using the exact wording from the error message I was getting. It has been a while and I should have kept notes, if I recall, I removed my 2 cards and placed a blank, newly formatted card in the R7 and then things went smoothly. Maybe older firmware already written to the card was confusing things. That I am not sure of, but I am sure of the wording from the error message I was getting.


I had the exact same issue with my R3. Thought it might've been something wrong with firmware update 1.3, so I've waited. And I still got the same error with the just released 1.4. Note: I had the same issue trying to update straight from the menu on the camera body.20230331_113836.jpg. I had tried with the older and even the latest EOS utlity apps with no luck. See screenshot for error. 

I also tried to reinstall the current firmware - 1.2.2 and got the exact same error message "Firmware cannot be downgraded". 

Screenshot 2023-03-31 113524.png

I figured out my own issue that may be relevant for the other posters here. I removed the CF Express card from the camera leaving the SDXC card in there (if your cam has two SD cards, remove one, make sure the other one is formatted). Firmware update runs from one single SD.  I do not have a CF Express card reader, so I have no way to actually look at the files on the card, but suspect maybe an older firmware was copied to the card at some point via the update process on the EOS Utility? Perhaps this is why formatting the SD's and CF Express is reccomended. Best of luck!



There might be something in the second card issue. I eventually got it work by removing both cards from my R7, manually copying the 1.3 FIR file to one card and also removing the old 1.2 FIR file from that card. I then upgraded from the R7’s menu with only the one card in the camera.

It would be nice if IOS Camera Connect and Windows EOS Utility just worked. Makes you wonder what is going on with Canon’s software group. 


There is.  These errors were due to the presence of an older .FIR file.  This is supported by the update completing successfully after removing the card with the older firmware version.  The EOS Utility does work,  It downloads a copy of the latest firmware.  It will not however remove older firmware versions.  This is why formatting a card first is recommended.  It ensures a "blank slate" and a file / folder structure the camera expects.

I just upgraded from >

I used my SDXC card.  I copied the FW to it using a card reader.  I did leave my CF Express B card in the camera.  Upgrade ran without issues.  I am certain the other card in my camera did not contain a .FIR file. If an earlier firmware version is present, the error will display.  

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~6D2 (v1.1.1) Retired ~EF Trinity, others ~DxO PhotoLab Elite ~Windows10/11 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It