Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R7 - Trying to use Camera Connect API - Connected once, can't anymore


Hi! I've tried to read everywhere and anywhere about this but I can't find a solution.

My boss sent me a new Canon EOS r7 for work. I want to take pictures and upload them to our server.

I set up using the Camera Control API connection tool and that went fine. Then I set up a connection and was able to access the camera with both, a small Ruby/Rails program I wrote and Postman.  After about 2 hours of fooling around the connection went away and I haven't been able to reconnect since. (This was Sunday and I've been trying Monday and Tuesday.)

I have read all about the problems with the R5 because my problem is the same. I get to the 'Search for access points' screen and it just stays at 'Searching...'. I've tried all the solutions. shutdown my mesh network completely, only has my main nodes of my mesh network up, walked around the neighborhood looking for any access points, drove around doing the same, but no luck. Still 'Searching'.

Is there any way I can do a hard reset on my camera? When I did a reset it still left the Connection tool. I was thinking maybe I could get back to the start.

I re flashed the latest firmware. v1.3.1. No joy.

Any thoughts would be appreciated.

Thanks in advance for the help.










Not applicable

Can't you delete the connection in the camera Wi-Fi settings and start fresh?

Thanks Bob! I tried but now I can't add a new connection because it needs to search for the access point and can't.  

Not applicable

I would suggest downloading the manual for the camera and start at page 656 that explains setting up Wi-Fi communications. Here is the manual download: 

Page 762 shows deleting all communications settings.


Thanks, but even though I can't connect there, the problem is the same, I'm trying to connect with the Camera Connect option which is under WiFi settings. 

But as I said, I have the same error trying to connect there also. My camera can no longer find an access point.


If you are experiencing issues with the Canon SDK, then you are in the wrong forum.  This forum is for end users, not software developers.

"The right mouse button is your friend."
Enter for a chance to win